cancel
Showing results for 
Search instead for 
Did you mean: 

G513QM Laptop would not turn on for days / once turned on would not shutdown.

revenantk
Level 7
I have a 6-month-old ROG Strix G513QM.

It's been working fine. But since yesterday it would not turn on, it would not even indicate the power adapter is plugged in.

I unplugged it and kept it till today after reading somewhere that it worked after we days.
As expected it turned on today morning and I immediately ran update checks for both drivers and windows. There were no pending updates as the system was already up-to-date.

Then I plugged in the AC adapter and let the system run for an hour or so. But when I tried to shut the system down, it would Immediately reboot after shutting down.
Tried sfc /scannow to see if windows were corrupted, but it wasn't.
Did a virus scan, but nothing was found.

Then reset windows cleaning all apps and files. Still, it would shut down and reboot immediately.

At the end vein, kept held the power button down for some seconds, and the system turned off. Since then it would not again power on as it was yesterday. One additional thing is noticed was the Armory Create on every startup tried to download and install 'a core service' and would ask to restart the system but it never went away and it would do that on each startup.

What would be the issue?

TIA
593 Views
1 REPLY 1

xeromist
Moderator
If the system is refusing to power on then that is not a Windows or software issue. If it's only 6-mo old you should contact ASUS support and request an RMA.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…