Showing results for 
Search instead for 
Did you mean: 

Everytime i type my microphone toggles on and off by itself

Level 7

I was just playing some games until suddenly every time I press a key on the keyboard my microphone got turned off and when I pressed another key it got turned on. This is so annoying and I can't find a way to fix it.

A few weeks earlier a similar thing happened but it changes my performance mode which I can fix with end tasking armoury crate. But this time I don't know what I have to do.

Any help will be appreciated.

I was using Asus ROG G512LI 


Level 7

Same Here bro

Level 8

Hello all,

So this problem happened to me last night as well and found this thread where others have the issue.  I use a mini Corsair RGB keyboard for gaming which has no issues and works as intended - but when i touch any key on the actual ROG laptop it toggles the microphone on and off. This happens whether my Corsair device in plugged in or not. I also have an Ironclaw Gming Mouse and Corsair Void Headset (which has the separate master mic on/off button on it). I use iCue to switch game profiles as well. So potentially conflicting issues anywhere in that lot.

I believe i have fixed it but not 100% sure what actually did the job so let me list everything i tried and you can replicate them.

1. Disconnect all USB devices and reboot. Tried this about 2 or 3 times with a variety of combinations.

2. If using Corsair etc check for updates in the third party software (iCue in my case for firmware updates or settings which affect macros etc)

3. Check ASUS Armoury Crate for updates - i had 3 waiting i didn't realise even though none of them were to do with the touchpad or keyboard. As its the ASUS microphone symbol that flashes on the screen afterall i feel this is likely the area where the problem truly lies.

4. Check My ASUS for software updates - again i had one waiting but not sure what it was for.

5. Finally go START type MSCONFIG and choose the app. Select SERVICES tab. I then deselcted the ASUS services and applied it. Select STARTUP tab and open Task Manager. Here i played around a bit and disabled the lot. When you click OK and close out it will prompt a computer restart. When it boots again you won't have many of the task tray icons since you didnt run them. Repeat from the start of this comment and re-enable services. Restart computer. Might need to play around a bit here and be selective and do one by one or the job lot like i did.

6. Whilst doing some of the things in step 5 i had ASUS Armoury Crate services stopped and then clicked to open the Crate at which point it took ages to open then prompted me to install it...? I was a bit confused since i knew i had stopped the service but never uninstalled it. Either way i did as asked and then made sure it was active under MSCONFIG from step 5 and restarted my laptop. At this point i could press the keys as normal and no problems. 

As i type this epic saga i am 3 hours post 'fix' and the issue has not repeated itself.

Device is 2022 ASUS Rog Zephyrus G15 GA503RW