Showing results for 
Search instead for 
Did you mean: 

EGPU not working on GL553V

Level 7
So, recentely I acquired a more powerful EGPU for my laptops. As an owner of two, I gladly used it with my "for work" one, but coming to a second thought, I assumed that GTX 1070 would prove to be better than 1050. So in the end I ended up using it on my Gaming Laptop too resulting in me wasting money.

Furthermore, the model of the EGPU is from Gigabyte (as official ASUS devices were not in my region). Full name that I got is: AORUS GTX 1070 GAMING BOX GV-N1070IXEB-8GD. Finding out that GL553V only supports 2-nd gen and by extent only 20/40 gbps/s it was kind of sad but I still tried it. I ended up connecting it through thunderbolt and.... The system did not detect the EGPU. It had the plug-in sound and everything yet the OS did not want to detect it giving me an error code 10 saying that the following device did not exist.

I have not tried any "out-of-class" things but so far I have tried simple methods:

1. Going to device manager and toggling the device off and on resulting in the same problem.
2. Updating the drivers that were already on the top of the shelf.

I did not do anything with safe mode neither did I screw around with BIOS *which is pointless, of course.*

I have not tried much but thats all I could think of to fix the problem.

I also have not done enough resarch on GIGABYTE and exactly on its compability on 2nd gen but Im more than sure that it should.

In any case I really look forward for your help.

Update: Tried safe mode (standard one without lading net drivers and etc. but it still did nto work. Im going to try disabling fast boot at this point.
UPD2: Fast booting also didnt work. Honestly, at this point I have no idea what to do.
UPD3: BIOS did not show any signs of eGPU connecting overall. Bios version is 309 if that's required.

Level 7
GL553 type c ports are not thunderbolt, it's just an USB in fancy shape.