cancel
Showing results for 
Search instead for 
Did you mean: 

Display issue on Asus G74SX ? Screen go's grey then black

Thorn2011
Level 10
As it said in my title, I have had this issue twice now where I will be just sitting in Windows browsing away, then all of a sudden my screen blinks, go's grey then black.... I can hear windows operating in the background normally but there is no way to get the display back on, I have to hold down the power switch, power off then back on!

Everything else seems to work normally I don't understand, I can game for hours and it is fine, no graphical issues at all, is this likely a display driver issue (it has only done it since upgrading my video drivers to 301.42 although this could just be random) OR is it likely a display issue?

Anyone else have this happen? Both events were weeks apart and apart from that my G74 hasn't missed a beat? Thanks, I really don't want to have to send laptop away to Asus, and chances are they won't be able to replicate the problem in the amount of time that they have it for!

EDIT:

One other thing I noticed, especially the first time I had this issue, is everything started getting REALLY slow with my Laptop, I remember playing a game of solitaire and it looked like it was in slow motion almost, soon after the grey then black screen happened... not sure if this helps diagnose the problem or not but there you go!

Thanks!
Asus G74SX-FHD-TZ130V

2nd Generation Intel Core i7-2630qm 2ghz With Turbo Boost Up To 2.9ghz CPU | Metallic Keyboard | Win 7 Home Premium | Blu Ray & DVD +/- & CD Player | 4 USB Ports | Media Card Reader | Webcam | Bluetooth | WIFI | Nvidia 3D Vision GTX560M 3GB | 2 X 750GB 7200rpm HDD's | 8 GB RAM DDR3 1333mhz | 17 Inch Screen 1920X1080 Resolution | 1 HDMI Ports | 8 Cell Battery
6,913 Views
10 REPLIES 10

Thorn2011
Level 10
Anyone here from Asus who could help, OR does anyone know who I can call here in Australia to help? Thanks!
Asus G74SX-FHD-TZ130V

2nd Generation Intel Core i7-2630qm 2ghz With Turbo Boost Up To 2.9ghz CPU | Metallic Keyboard | Win 7 Home Premium | Blu Ray & DVD +/- & CD Player | 4 USB Ports | Media Card Reader | Webcam | Bluetooth | WIFI | Nvidia 3D Vision GTX560M 3GB | 2 X 750GB 7200rpm HDD's | 8 GB RAM DDR3 1333mhz | 17 Inch Screen 1920X1080 Resolution | 1 HDMI Ports | 8 Cell Battery

Zka17
Level 16
You may have more success in getting an answer in the laptop section...

One thing, however... if you have your nvidia driver on auto update, it will auto update... and then troubles start... - at least that's happening on desktops...

I would try uninstall all the nvidia stuff, clean up the mess it left behind with Driver Sweaper (in Safe Mode), then reinstall the last known good driver - and immediately turn off the auto update thing!

Zka17 wrote:
You may have more success in getting an answer in the laptop section...

One thing, however... if you have your nvidia driver on auto update, it will auto update... and then troubles start... - at least that's happening on desktops...

I would try uninstall all the nvidia stuff, clean up the mess it left behind with Driver Sweaper (in Safe Mode), then reinstall the last known good driver - and immediately turn off the auto update thing!


Yeah that is why I have Auto update off 🙂 Last time I upgraded (to the 301 driver) I did a driver sweep but not in safe mode though? It just seems strange that it never happened before updating to this version of driver, it might be worth rolling back if it happens again? I think the newer Nvidia drivers are a little dodgy on particular systems?
Asus G74SX-FHD-TZ130V

2nd Generation Intel Core i7-2630qm 2ghz With Turbo Boost Up To 2.9ghz CPU | Metallic Keyboard | Win 7 Home Premium | Blu Ray & DVD +/- & CD Player | 4 USB Ports | Media Card Reader | Webcam | Bluetooth | WIFI | Nvidia 3D Vision GTX560M 3GB | 2 X 750GB 7200rpm HDD's | 8 GB RAM DDR3 1333mhz | 17 Inch Screen 1920X1080 Resolution | 1 HDMI Ports | 8 Cell Battery

cl-scott
Level 12
The Asus Australia number is: 1300-278788

And before working for Asus, I was an Apple repair tech. This issue sounds kind of like one that hit their unibody MacBook line, so you can see if maybe moving the clamshell (display) back and forth will make any difference.

I didn't actually try that, instead I hit every button on the keyboard but that didn't seem to make any difference, on power off-on everything went back to normal? If it is a display issue then I am not sure why its only just started in the last few months, if it is a display driver though, (which is what I am hoping, much easier to fix!) then I will just roll back to one of the 290 certified drivers and see if the problem persists?
Asus G74SX-FHD-TZ130V

2nd Generation Intel Core i7-2630qm 2ghz With Turbo Boost Up To 2.9ghz CPU | Metallic Keyboard | Win 7 Home Premium | Blu Ray & DVD +/- & CD Player | 4 USB Ports | Media Card Reader | Webcam | Bluetooth | WIFI | Nvidia 3D Vision GTX560M 3GB | 2 X 750GB 7200rpm HDD's | 8 GB RAM DDR3 1333mhz | 17 Inch Screen 1920X1080 Resolution | 1 HDMI Ports | 8 Cell Battery

Zka17
Level 16
I think, it may worth to give a try with an older driver...

I've been having this exact same problem. Just downgraded my Nvidia drivers to 296.16 today. Will let you know if that resolves it. Happens at least 2x per day now.

dstrakele
Level 14
@Thorn's post that his laptop appeared to be functioning in slow motion prior to getting the grey, then black screen is interesting. It makes me wonder if this issue is caused by a process or thread going haywire and using 100% CPU utilization. If that is the case, Process Explorer may be able to identify the problem process or thread, leading to a resolution.
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Downgraded Nvidia drivers did not fix this issue.

That said, in the next couple of weeks I'm intending to put an SSD in this thing and then re-load the OS from scratch. We'll see then! Unless someone figures it out before that point.