Showing results for 
Search instead for 
Did you mean: 

BIOS LAG on GL703GS, Unable to update the BIOS.

Level 7
I own a GL703GS-DS74 laptop.
When I press F2 while starting my laptop, the UEFI BIOS screen appears only after 40-60 seconds. After entering the UEFI mode, the mouse pointer does not move and when I press on any arrow key on my keyboard, the response to the keypress is visible only after 2 mintues. The BIOS is very slow. Then I wait patiently after pressing F7 to go to advanced mode. The advanced mode comes only after 2 minutes of waiting. This is where things get worst. In the advanced mode every key press takes 4-5 minutes to respond. The current BIOS version is 301. A new version was released two months ago and I came to know that only now. So inorder to flash the BIOS, I have to use the EZFlash utility in the BIOS. I am unable to get to that part since it is taking forever to navigate through the BIOS. I tried to flash the BIOS via WinFlash tool. Once I select update BIOS, the progress bar fills up and then a pop up appears saying that, "The system will restart to continue BIOS update". Upon pressing EXIT, the laptop shuts down and does not restart by itself. If I press the power button again, the laptop starts normally. There is no BIOS update screen or anything related to that. The laptop boots directly to WIn 10 and there has been no update to the BIOS. Then I open the WinFlash tool again only to find that the version of BIOS is still 301. I also tried resetting the BIOS by removing the CMOS battery. The BIOS gets reset but it still is laggy as hell. I tried removing all devices connected to the laptop. Even the SSD and the HDD were removed. Even after that the BIOS is still laggy. Is there any solution to this? Please help me out.