cancel
Showing results for 
Search instead for 
Did you mean: 

AURA Advanced (Custom effects not working) on Strix Scar 3 (G531GW) - [solved]

DScrete
Level 7
I've recently bought a Strix Scar 3 (G531GW) as mentioned in the title and seem to be having an issue getting custom rgb settings to work.

So I'm hoping someone's had a similar problem and knows a fix. Basically I'm having trouble applying advanced Aura settings.

Upon opening Aura Creator, I previously had an issue where it would simply not detect any devices. Reinstalling Armoury Crate and Aura Creator seems to have fixed this though. However, now when creating custom aura profiles in Aura creator, upon preview, no lights light up. When I have fully created and saved these profile. All that occurs is a message saying "Applying Advanced Effect", yet nothing happens.

I have already tried reinstalling all relevant drivers and utilities without success. If anyone knows a fix, any help would be appreciated.
4,246 Views
2 REPLIES 2

DScrete
Level 7
So in case anyone has the same issue, I managed to fix it. I saw one solution saying to change the language to English. I dismissed at the time because my language was already English but turns out it specifically needs to be US english. Changing that solved my issue

You mean change the windows language to US English or the Aura language to English? I can't find any setting in Asus Armoury or in Asus Aura to change the language. You're the only other case of this I've found online.