cancel
Showing results for 
Search instead for 
Did you mean: 

ATK Package v1.0.0061 can't be installed in GL703GM

GeoBRB
Level 10
Hello all.
I want to install the latest version of ATK Package v1.0.0061 from the official website.
Downloaded, extracted, but when I try to install appear an window with error message:

"Unable to install because the setup is not applicable to your computer"

The official download link is here:

https://dlcdnets.asus.com/pub/ASUS/GamingNB/AppforWin10/ATKpackage/ATKPackage_V100061.zip

All of the previous versions can be installed without errors, but the latest version return the above message.

I have Windows 10 Pro x64 RETAIL with digital license.

Beside I try to run the setup in the other Desktop PC, non-ASUS, with Windows 10 Pro x86 not x64 and the setup leave to install :rolleyes:

What can I do? Someone has this issue?
3,289 Views
0 REPLIES 0