cancel
Showing results for 
Search instead for 
Did you mean: 

Asus strix scar g733qs bios 3.15

sebarkh
Level 9
I see new bios update in the MyAsus app 3.15, I try use ASUS_G733QS_315_BIOS_Update.exe in Windows, but the installer just asks to restart the computer, but skips bios and returns to windows without updating. I know I can update thru Bios directly,but I wonder why the installer not workin... I'm on 3.13 Bios right now.
678 Views
9 REPLIES 9

flyingsoap1984
Level 7
I wonder if they tested these bios for windows installer lol

I've got G713QR and the windows installer did the same thing 😛

I don't have an external usb drive yet and a bit skeptical to install the actual bios since the windows installer has failed to kick it off as well.

sebarkh
Level 9
I did it thru USB and... I almost got a heart attack when the laptop rebooted and there was a black screen... and again... the same... after the third forced reboot I kept the Power button pressed for 50 seconds (they say 40 is enough to reset) ant .... the same the black screen...
But... after I rebooted it again the screen went on... I'm 10 years older... and have white hair hehehe....

Asus, please kindly take a look and update the bios.

I'll just wait for the next version to be available before I update again.

To scared to update to 315 bios lol.

i have the g733qs, i'm afraid to update too, anyone know what exactly it changes with this version?

sebarkh wrote:
I did it thru USB and... I almost got a heart attack when the laptop rebooted and there was a black screen... and again... the same... after the third forced reboot I kept the Power button pressed for 50 seconds (they say 40 is enough to reset) ant .... the same the black screen...
But... after I rebooted it again the screen went on... I'm 10 years older... and have white hair hehehe....


I couldn't flash the update either way. After the hard reset were u running 315? Or did it revert back to previous BIOS?

FluxX17 wrote:
I couldn't flash the update either way. After the hard reset were u running 315? Or did it revert back to previous BIOS?



It goes well thru USB when you enter EZ BIOS Update option and choose the file on your USB.
After the update everyting works just fine (not counting 5 minutes of fear when the display went only after the 5th try).

G533QR here. I have updated via USB drive in BIOS EzFlash itself. Also in my case the installer just rebooted the PC and nothing else. I haven't noticed any improvement regarding sleep mode - still can't put laptop to sleep. Also Airplane Mode LED is still lit at all times.

genuineoleey wrote:
G533QR here. I have updated via USB drive in BIOS EzFlash itself. Also in my case the installer just rebooted the PC and nothing else. I haven't noticed any improvement regarding sleep mode - still can't put laptop to sleep. Also Airplane Mode LED is still lit at all times.


Concerning the non-stop LED: When you keep the power button pressed for more than 40 seconds it should reset the battery - the LED keeps on then, after the reset?

sebarkh wrote:
Concerning the non-stop LED: When you keep the power button pressed for more than 40 seconds it should reset the battery - the LED keeps on then, after the reset?


I did that and it didn't change the behaviour of the LED. I've noticed, that after reset the laptop is booting longer than usually (black screen before ROG logo appeared), but the LED is still ON. It looks like it's hard short-circuited, because when I shut down the laptop, both - the power LED and red power button LED go off, except Airplane Mode LED, which is still ON for 4-5 more seconds until all electronics goes off.