Showing results for 
Search instead for 
Did you mean: 

ASUS Strix GL753V issues

Level 7
Hi, two months ago I bought a GL753VD wich came with a preinstalled, licenced Windows 10 64bit. After the self-evident clean windows 10 64 bit install on a separately purchased M.2 SSD, I have several problems with this laptop (I never imagined that ROG laptops can have these kind of issues and ASUS not doing anything for months, i've been reading this forum since day two of the purchase and I'm stupefied, it's a big disappointment):

1. the touchpad: when scrolling with two fingers in web browsers (Opera, Chrome, Firefox), Adobe reader, Open office, Mozilla thunderbird, the page just jumps back randomly. I already have the latest drivers from the ASUS site, doesn't work. Since I am using a NVME M.2 SSD for the clean win install, I still have the factory preinstalled Windows 10 64 bit on the 2.5 HDD. The problem is present when booting to that Windows too. Pinch zoom is off from windows's own mouse and touchpad settings. Reading this forum I realized that several ROG laptops have the same problem or other touchpad related problems (G752 for example). I know it's not the same touchpad but it's Elan. On the Elan's website there are NO drivers for their products. I think this issue is driver related and if it's not Elan, it's ASUS.

2. USB ports on the left side of the laptop: external HDD connects then disconnects after a few seconds. These two USB ports are unuseable. Again, several "generations" of ROG laptops have the same problem with these two ports. USB 3G modem not working in these two ports. I have 5 USB flash drives, three of them are not working in these ports, two of them are working. On the right side of the laptop 5/5 are working. My HTC phone is not connecting to those ports. The USB type C port on the left side seems to work fine with a USB type C SDcard reader and with a mobile phone connected. Logitech's unifying receiver is working in both of the USB ports, I have to use a mouse because of the touchpad problem. I've connected an external HDD with external power source: no problems at all, connecting, copying with USB 2 speeds as featured. I think this is a hardware related problem, insufficient power to those ports. When I installed the SSD i saw that those two USB ports are on a separate circuit board from the motherboard just like on other ROG laptops (eg.G752, GL751 as others on this forum already mentioned).

3. Cracking sound: loud crack just before playing any kind of sound - most annoying with windows sounds. Latest driver from ASUS doesn't solve this problem nor drivers from Realtek's site. I think it's driver related. I already tried different power management settings (maximum performance avoiding the system to power down components, different drivers, the problem is present on the preinstalled windows and on the clean windows too. Multimedia is a joke with this laptop's cracking sound.

I don't want my money back, I want these problems SOLVED. This is not a cheap laptop and I'm almost certain that problem 1 and problem 3 are driver related, so...

Level 7
Sound to me like you need to RMA if still within the return period return otherwise contact Asus support or cl-albert. Just remember to remove your NVME drive before sending in for RMA.

U2Desire, no, I am waiting for others to confirm the same behaviour, I am sure this is happening to others because of the multitude of problems with touchpads on ASUS ROG laptops - just search and read the forums. Yes, I know that there are different types of hardware on different ROG series, mine is Elan.

Here are some screen captures, Opera and Chrome, but the same thing is happening in Open Office and Adobe Reader.

Precision touchpad on GL753VD is completely unuseable at the moment. I have the latest drivers, changed Microsoft input configuration device to Asus input configuration device as recommanded by ASUS FAQ. Again, this is a "clean" Windows 10 64bit install, but this is the same on the preinstalled Windows 10 64bit also.

Level 7
All......... After receiving 2 new ones from Amazon, both having problems, I purchase a new GL702 and love it!!

I got the GL753VE and everything is working great except my left speaker doesn't seem to be working. Not a big deal since I'll be using a headset almost all the time but still thought I should add to the post.

If any one else has this issue I'd be interested to know.


P.S. --- My profile says "New ROGer"... I've owned 6 G series laptops and now my first GL series. I've used the ASUS Maximus IV, the ASUS Crosshair IV Formula and half a dozen other ASUS ROG PC parts. "New ROGer" my eye.
"Common sense is not so common." - Voltaire

I trust you checked the Balance settings in Speaker properties 😉

Windows just had an update on the 15th and it made my laptop not able to charge. I tried fixing it by restoring the laptop to factory setting and then block any windows updates but then it stopped halfway through the resetting saying there was an error. Then I tried downloading the BIOS but it still didn't work. Then I tried just opening it up and cleaning and maybe that would work but after unscrewing everything the cover seems to still be stuck to the motherboard around the middle. I hope they give a solution to this.

Under the rubber "L" shaped thing on the bottom cover there is a hidden screw which has to be removed in order to open up the laptop, but I don't think that cleaning will help. I would rather check the cables on the charger. With the laptop powered down is charge working?

As of today morning the touchpad cannot be disabled with Fn+F9. Pressing Fn+F9 shows the Touchpad is disabled onscreen display, but in the meantime touchpad is still working. I did not touch the drivers in the last few days, Windows didn't update, I generally use sleep mode not shut down. Restart doesn't help.

I own a gl553ve and after buying i noticed that one of my arrow keys was not working:(, nevertheless i got it replaced with a new keyboard right away
and since it was an onsite servive so i noticed how he opened the back. you have to remove that L shaped rubber, its a little sticky and you will thinnk you are breaking it , but is all right, also when closing you can just press it back & it will simply stick back.
don't remove the cover fully, just open it partially till you see the screw, and open up the screw.
when trying to open the back cover after removing the screw, using a prying tool credit card or something,etc. start from the hdmi port with a little force and till its inside and go all the way round, sliding the tool arounud laptop from back side ; and it will come up , now you can slowly lift up the cover to access the insides
for prying up the lid you can also start with the usb port on the other side and then go around other way.