cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Strix G15 Advantage Edition (G513QY) Flickering artifacts

lrmcatspaw
Level 7
Good day.

I have been trying to fix/isolate an annoying graphical issue with my laptop.
Games have been increasingly showing a strange artifact shown in the videos bellow. They are much more visible in person.
I have tried changing settings in both windows 10 (home edition) display settings as well as changing settings in AMD Adrenaline software to fix the issue without much luck.

The only thing that works is to enable or disable virtual super resolution in the AMD Adrenaline software.
This however only works until the next "loading screen". Then the issue returns.

I have also noticed that the issue is far more prevalent in more homogeneous textures than on areas where items differ in colors.

Please see the videos of this issue bellow.

https://www.youtube.com/watch?v=BAjoSytNLpI&ab_channel=dosduros
https://www.youtube.com/watch?v=XNJ3_4NlX64&ab_channel=dosduros

Any idea what this could be?

Thank you for any help.
2,145 Views
4 REPLIES 4

rat445533
Level 7
lrmcatspaw wrote:
Good day.

I have been trying to fix/isolate an annoying graphical issue with my laptop.
Games have been increasingly showing a strange artifact shown in the videos bellow. They are much more visible in person.
I have tried changing settings in both windows 10 (home edition) display settings as well as changing settings in AMD Adrenaline software to fix the issue without much luck.

The only thing that works is to enable or disable virtual super resolution in the AMD Adrenaline software.
This however only works until the next "loading screen". Then the issue returns.

I have also noticed that the issue is far more prevalent in more homogeneous textures than on areas where items differ in colors.

Please see the videos of this issue bellow.

https://www.youtube.com/watch?v=BAjoSytNLpI&ab_channel=dosduros
https://www.youtube.com/watch?v=XNJ3_4NlX64&ab_channel=dosduros

Any idea what this could be?

Thank you for any help.


This can be cable related or igpu high temps/overclock, try connecting directly to the usbc display port , and see what happens.

I encounter the same issue, but very randomly and not very often. In fact only in 1 game and that's sometimes. I will try your solution in the YT comments and report back (turning off panel overdrive in armoury crate).

Exactly same issue with my G513QY.
That occures while playing a game or watching a video.
I noticed that happens with screen refresh rate at 165hz. Since I only use 60hz mode, it's okay, no more these artefacts.

Jul83 wrote:
Exactly same issue with my G513QY.
That occures while playing a game or watching a video.
I noticed that happens with screen refresh rate at 165hz. Since I only use 60hz mode, it's okay, no more these artefacts.


I managed to fix it for now:
Turn off panel overdrive in asus armoury crate (might need to turn it off again when you update graphics driver).