cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix Scar II GL504GM - Battery to zero 0%

Marioss
Level 7
Hello,

I have Asus Rog Strix Scar II GL504GM, the issue im running into is about the battery. When my battery is below 50% (more or less) and the laptop is off, when i power it on, and it is NOT with charger on, it starts normally and when i see the log in screen, i see the battery on the down right corner on the percentage that it was before i shut it down, and sudenly goes to 0 and shuts down. And when i power it on again (with charger this time), it is 0%.

It is not draining when i shut it off, because this can be happen also if it is 50%, i shut it, and turn it on again after 15 minuts for example, so it is not drainage, also i see the percentage of the battery i had before i shuted, at least for 1 sec, so for a weird reason it remembers the % but then it goes to 0 and shuts it imediately. If it passes this second, and it not turned off, then its is ok, so sometimes it turns off, sometimes it waits for me to login as a normal boot procedure.

I have All latest windows updates, i have latest bios update 310, i am really really carefull with the laptop, not stress it, not force it, etc. I tried the tips i read on internet about fast boot, from computer or from bios or both, unistalled the Intel rapid storrage also that i read is not helping for that, also "delete" the battery from device manager so it installs its drivers again when it boots, still didnt help. The laptop is about 8 months new with extreme careful useage, and good battery charging.

Except this, the battery working fine, and this is happening once every 2-3 boots, sometimes on every boot, this is never happend when my battery was 100% charged on the last shutdown. I dont know i feel it is software issue not hardware/battery issue because it happens only sometimes not always. So guys did anyone had this issue before? can you suggest something to try? Thank tou in advance.
327 Views
278 REPLIES 278

PTSONIC wrote:
Can you confirm that your "solution" still works today?

Yeah, I'm using this method since I discovered it and it still works!

alma23 wrote:
Yeah, I'm using this method since I discovered it and it still works!


It also works if you set to 80% if you wish to have more than 60%.

Hello People!

Does Anyone have news about this issue?
Blake@ASUS maybe!?

Are we still in the same situation!?

mIKE_Aleph wrote:
Hello People!

Does Anyone have news about this issue?
Blake@ASUS maybe!?

Are we still in the same situation!?


We're still in the same situation, it seems that ASUS does not give a s**t about this problem, anyway it is clearly a software related issue, read my last posts for a workaround.

Did you install the latest?

My ASUS 2.3.11.00 and Asus Control Interface v1.0.34.0

alma23 wrote:
We're still in the same situation, it seems that ASUS does not give a s**t about this problem, anyway it is clearly a software related issue, read my last posts for a workaround.


Sadly your "workaround" doesn't even work on my laptop. The battery still drains overnight.

PTSONIC wrote:
Sadly your "workaround" doesn't even work on my laptop. The battery still drains overnight.
Well I dont expect our laptop will stay long in our battery since it consumes more power

silvergem wrote:
Well I dont expect our laptop will stay long in our battery since it consumes more power


If only I didn't need my laptop every single day because of online classes, I would've sent it to the repair center right away. Issues like these are unacceptable for a laptop with less than 2 years!

Blake@ROG wrote:
Dear all,
We are working on this issue, we just made some progress.
Thank you to some users' support on this.
If there is anything new, I will let you know.
Thank you.


It's been around a year and I don't see a fix regarding this issue.

I have a scar 2 GL504GV with the same issue I turn it off @ 100% in the night. In the morning when I wake up I first boot into bios to check and it shows 100. I let it discharge till 95 and it doesn't turn off in between but as soon as I hit the windows lock screen the battery is 0 and the laptop dies and doesn't turn on without a charger.

I have been using the laptop on AC all the time since December 2020 due to this problem.

I can't believe I paid 1500$ for a laptop from a company that is completely unprofessional and has terrible after sales support.
I can see no replies from anybody at ASUS on this thread.

WHAT ARE WE SUPPOSED TO DO??
Continue using this laptop as a desktop forever!!

I will never buy ASUS laptops again. What a waste for money!