cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix Scar II GL504GM - Battery to zero 0%

Marioss
Level 7
Hello,

I have Asus Rog Strix Scar II GL504GM, the issue im running into is about the battery. When my battery is below 50% (more or less) and the laptop is off, when i power it on, and it is NOT with charger on, it starts normally and when i see the log in screen, i see the battery on the down right corner on the percentage that it was before i shut it down, and sudenly goes to 0 and shuts down. And when i power it on again (with charger this time), it is 0%.

It is not draining when i shut it off, because this can be happen also if it is 50%, i shut it, and turn it on again after 15 minuts for example, so it is not drainage, also i see the percentage of the battery i had before i shuted, at least for 1 sec, so for a weird reason it remembers the % but then it goes to 0 and shuts it imediately. If it passes this second, and it not turned off, then its is ok, so sometimes it turns off, sometimes it waits for me to login as a normal boot procedure.

I have All latest windows updates, i have latest bios update 310, i am really really carefull with the laptop, not stress it, not force it, etc. I tried the tips i read on internet about fast boot, from computer or from bios or both, unistalled the Intel rapid storrage also that i read is not helping for that, also "delete" the battery from device manager so it installs its drivers again when it boots, still didnt help. The laptop is about 8 months new with extreme careful useage, and good battery charging.

Except this, the battery working fine, and this is happening once every 2-3 boots, sometimes on every boot, this is never happend when my battery was 100% charged on the last shutdown. I dont know i feel it is software issue not hardware/battery issue because it happens only sometimes not always. So guys did anyone had this issue before? can you suggest something to try? Thank tou in advance.
365 Views
278 REPLIES 278

thafunker wrote:
85329


Now it shows 54.4% battery wear, was at 8.4% before the crash.


Same Crash Issue sir. Owner of a GL504GW. Wear level was at 14% now it is at 74%

thafunker wrote:
85329


Now it shows 54.4% battery wear, was at 8.4% before the crash.


Owner of GL504GW.
Before the crash wear level was at 19% now its at 74%
Any way to bring it back to normal Levels?

Alrighty
Many people have reported that they accidently charged their batteries to 100% and the issue got fixed
Owner of GL504GW86977

silvergem wrote:
HOw u install the armoury crate on GL504GM??


I am sure Armoury Crate came pre-installed on your pc, being GL504GM.
a) When did you buy the laptop?
b) Did you purge out bloatware when initially setting up your pc? Maybe you removed AC during that time.
c) Check in ADD REMOVE programs if you have it?

If (c) is yes
c) type Armoury in the windows start search box and see if any suggestions come up?
d) press ROG key (on top of F4 key near the volume buttons) and see if armoury crate opens.

If (c) is no
e) You need to install Armoury crate from Windows store.
f) before installing AC from windows store, check that you have required services installed i.e. "Armoury crate service", "ROG live service" and "Refresh rate service". You can find latest versions of these services from ASUS product support page for your laptop.

Hope it helps, let me know 🙂

thafunker, enrique and others,
Sorry for asking so many questions but I am trying to find something common for all having this problem.

a) Are you guys using ASUS Battery Health Charging on "Balanced" or "Maximum lifespan" mode and keeping the charger plugged in during normal usage?

b) Are you calibrating the battery once every month or so?

Hello Everybody... Just reading this post.
I have the same issue, Battery drop to 0% for no reason.

I have my GL704GM since December last year, I found about the problem about a month ago.

I did a clean Win 10 Install, (since windows broke down by flickering screen), and installed all last Asus Drivers...
I realized that the battery drop to 0% problem, started after installing My Asus Software from Microsoft Store

By reading the post I'm trying updating the bios through device manager > firmware > system firmware
It Updated to version GL704GM.309
I will now make a Win 10 clean install and let you know how it goes.

It's been about four months since this thread started; it would be Really Nice if ASUS could give a straight Answer.
I'm also a fan of Asus, and love the Rog Strix Scar II, but they need to solve this issue.

Same battery wear which is 56%. Now this was gone after few days which accidentally charge up to 100%. This happened since the Myasus app became buggy lately and not opened on as startup program which i configured my laptop to charge only up to 60%.

After that the Battery wear is now only 12-14%
85398

silvergem wrote:
Same battery wear which is 56%. Now this was gone after few days which accidentally charge up to 100%. This happened since the Myasus app became buggy lately and not opened on as startup program which i configured my laptop to charge only up to 60%.

After that the Battery wear is now only 12-14%
85398



Issue was back again, when I Opened my laptop it went to 0%. then the wear level is 36%

mbushnaq00
Level 10
ASUS has recently released BIOS version 306 for the SCAR II GL504GW. The update is not available on the ASUS driver website yet, however, you can update through device manager > firmware > system firmware.

Also, I would like to mention that the issue stopped happening with me for the past week. I am not sure what is the reason, but I have done the following:

- Did a "Refresh this PC" and reinstalled all my apps.
- Performed a driver cleanup using "DriveStoreExplorer" and removed outdated and unused drivers (it turns out "Refresh this PC" retains all the drivers installed even after the refresh is completed)
- Updated Windows 10 to the latest version 2004
- Updated IMEI to version 1952.14.10.1470
- Updated Intel Dynamic Tuning to version 8.7.10200.12510
- Updated Intel Rapid Storage Technology to version 17.8.0.1065
- Did a lot of battery charge/discharge cycles, however not going below 20%.

Now everytime I boot my PC the next day, even if its at 30% battery, it would function normally.

I would like to mention that I have never replaced the battery or done any hardware changes on the laptop.

mbushnaq00 wrote:
ASUS has recently released BIOS version 306 for the SCAR II GL504GW. The update is not available on the ASUS driver website yet, however, you can update through device manager > firmware > system firmware.

Also, I would like to mention that the issue stopped happening with me for the past week. I am not sure what is the reason, but I have done the following:

- Did a "Refresh this PC" and reinstalled all my apps.
- Performed a driver cleanup using "DriveStoreExplorer" and removed outdated and unused drivers (it turns out "Refresh this PC" retains all the drivers installed even after the refresh is completed)
- Updated Windows 10 to the latest version 2004
- Updated IMEI to version 1952.14.10.1470
- Updated Intel Dynamic Tuning to version 8.7.10200.12510
- Updated Intel Rapid Storage Technology to version 17.8.0.1065
- Did a lot of battery charge/discharge cycles, however not going below 20%.

Now everytime I boot my PC the next day, even if its at 30% battery, it would function normally.

I would like to mention that I have never replaced the battery or done any hardware changes on the laptop.


Hi mbushnaq,

By refresh do you mean the "reset" through WIndows?
Are you able to link or screenshot all of this procedure for not so savvy people like myself? Thanks.