cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix Scar II GL504GM - Battery to zero 0%

Marioss
Level 7
Hello,

I have Asus Rog Strix Scar II GL504GM, the issue im running into is about the battery. When my battery is below 50% (more or less) and the laptop is off, when i power it on, and it is NOT with charger on, it starts normally and when i see the log in screen, i see the battery on the down right corner on the percentage that it was before i shut it down, and sudenly goes to 0 and shuts down. And when i power it on again (with charger this time), it is 0%.

It is not draining when i shut it off, because this can be happen also if it is 50%, i shut it, and turn it on again after 15 minuts for example, so it is not drainage, also i see the percentage of the battery i had before i shuted, at least for 1 sec, so for a weird reason it remembers the % but then it goes to 0 and shuts it imediately. If it passes this second, and it not turned off, then its is ok, so sometimes it turns off, sometimes it waits for me to login as a normal boot procedure.

I have All latest windows updates, i have latest bios update 310, i am really really carefull with the laptop, not stress it, not force it, etc. I tried the tips i read on internet about fast boot, from computer or from bios or both, unistalled the Intel rapid storrage also that i read is not helping for that, also "delete" the battery from device manager so it installs its drivers again when it boots, still didnt help. The laptop is about 8 months new with extreme careful useage, and good battery charging.

Except this, the battery working fine, and this is happening once every 2-3 boots, sometimes on every boot, this is never happend when my battery was 100% charged on the last shutdown. I dont know i feel it is software issue not hardware/battery issue because it happens only sometimes not always. So guys did anyone had this issue before? can you suggest something to try? Thank tou in advance.
284 Views
278 REPLIES 278

Sergio8903 wrote:
Hello, the notebook is still at the service of Milan now from 1 week.

This is the second time I send the notebook, the firs time 3 month ago the service of Rome change me the battery for 62 euro because it was damage and the battery hace only 1 year of warranty, but the problem still there. So I decide to resend another time, and is 1 week that the notebook is at the service of Milan


Hi Sergio, i really hope to fix this problem. Please sent as a feedback when you receive the laptop!

enriquecs2005 wrote:
Hi Sergio, i really hope to fix this problem. Please sent as a feedback when you receive the laptop!


Hello guys,

The laptop arrived yesterday and I'm trying to see if the problem is solved.
From asus they change the mother board and but I think for other problem the fans anche the keyboard.
The bios version is the 311.

The laptop arrived with 52% of battery, i discharge to 35% and I turn off. After more then 6 hours, I turn on and was all ok 34% no problems. So I decide to discharge to the 29% and turn off and after 1 night today in the morning I turn on and all was OK 28%.

So for the moment the problem is solved, I will try to do more tests in this days.

Hey Sergio, any update? Hope the problem is resolved for you.
If so, can you please check in your power settings if the fast startup is enabled or disabled..
Also same for wake timers in advanced power settings
Thanks

vashish27 wrote:
Hey Sergio, any update? Hope the problem is resolved for you.
If so, can you please check in your power settings if the fast startup is enabled or disabled..
Also same for wake timers in advanced power settings
Thanks


Problem solved

The fast startup is enable and the fastboot in the bios is enable.

But now i have another problem, after the update at 2004 of windows , if before the battery life, watching a movie or surfing the internet was 4/5 hours, now it is maximum 2 hours.

Good to know,
I hope you are using "silent" or "windows" mode in Armoury crate software. You can check corresponding settings in windows power options. If you choose "balanced" in Armoury, then it will generally apply high performance power settings.
I recently upgraded to Windows 2004, got some other issues but not related to battery life.

Sergio8903 wrote:
Problem solved

The fast startup is enable and the fastboot in the bios is enable.

But now i have another problem, after the update at 2004 of windows , if before the battery life, watching a movie or surfing the internet was 4/5 hours, now it is maximum 2 hours.


Good to know,
I hope you are using "silent" or "windows" mode in Armoury crate software. You can check corresponding settings in windows power options. If you choose "balanced" in Armoury, then it will generally apply high performance power settings.
I recently upgraded to Windows 2004, got some other issues but not related to battery life

vashish27 wrote:
Good to know,
I hope you are using "silent" or "windows" mode in Armoury crate software. You can check corresponding settings in windows power options. If you choose "balanced" in Armoury, then it will generally apply high performance power settings.
I recently upgraded to Windows 2004, got some other issues but not related to battery life


HOw u install the armoury crate on GL504GM??

Hey everyone, i made a video that show the problem.
Battery was at 51% before the crash at 0%

https://youtu.be/8oPM4hnyW4Q

85329


Now it shows 54.4% battery wear, was at 8.4% before the crash.

Today I turned on the laptop, 71% battery, I entered the Browser and immediately the battery dropped to 0% , wear level 77% (normally 18% )...