cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix Scar II GL504GM - Battery to zero 0%

Marioss
Level 7
Hello,

I have Asus Rog Strix Scar II GL504GM, the issue im running into is about the battery. When my battery is below 50% (more or less) and the laptop is off, when i power it on, and it is NOT with charger on, it starts normally and when i see the log in screen, i see the battery on the down right corner on the percentage that it was before i shut it down, and sudenly goes to 0 and shuts down. And when i power it on again (with charger this time), it is 0%.

It is not draining when i shut it off, because this can be happen also if it is 50%, i shut it, and turn it on again after 15 minuts for example, so it is not drainage, also i see the percentage of the battery i had before i shuted, at least for 1 sec, so for a weird reason it remembers the % but then it goes to 0 and shuts it imediately. If it passes this second, and it not turned off, then its is ok, so sometimes it turns off, sometimes it waits for me to login as a normal boot procedure.

I have All latest windows updates, i have latest bios update 310, i am really really carefull with the laptop, not stress it, not force it, etc. I tried the tips i read on internet about fast boot, from computer or from bios or both, unistalled the Intel rapid storrage also that i read is not helping for that, also "delete" the battery from device manager so it installs its drivers again when it boots, still didnt help. The laptop is about 8 months new with extreme careful useage, and good battery charging.

Except this, the battery working fine, and this is happening once every 2-3 boots, sometimes on every boot, this is never happend when my battery was 100% charged on the last shutdown. I dont know i feel it is software issue not hardware/battery issue because it happens only sometimes not always. So guys did anyone had this issue before? can you suggest something to try? Thank tou in advance.
168 Views
278 REPLIES 278

Hi all,
@thafunker, @gieffe22, @Marioss, (thafunker and TX2000 already seen this) one year ago I have opened this thread regarding this problem in here .

As you can see from post #15 the issue was still present even after just 1 month the first RMA, so they changed my faulty battery with another faulty battery and in the second RMA nothing was done by asus support (portugal). You can see all the battery reports later after that post.

So from my point of view all batteries I was given were faulty and when laptop is plugged in with 100% I think there is no function that interrupts the course of electricity through the battery, because before my first RMA when I was playing the battery was dropping even if plugged in, and this is the biggest fault in a laptop in my opinion.

Blake reached out to me too and I would like to keep this current thread as the official one.

gieffe22
Level 7
So... guy's, Blake finally contacted me again, saing to send laptop on the HQ center to analize and "experiment" to find the problem. I just denied it because can't remain AGAIN (for the 3 time in 1 year) without my working laptop; so, i still hope in a bios fix... maybe if someone send the pc to these guys let us know...

gieffe22 wrote:
So... guy's, Blake finally contacted me again, saing to send laptop on the HQ center to analize and "experiment" to find the problem. I just denied it because can't remain AGAIN (for the 3 time in 1 year) without my working laptop; so, i still hope in a bios fix... maybe if someone send the pc to these guys let us know...


so we basically came to a dead end 😞

mbushnaq00 wrote:
so we basically came to a dead end 😞


maybe some other guy that not use laptop for work may decide to send to asus for those "experiments"... i just hope in this... honestly i was thinking in better but that's it, noow at least they know the problem officially...

Maybe Blake can tell as if the new version of bios 312resolve the problem. Marioss didn't feedback... Come on Asus don't disappoint us... I'm really an Asus fan but if this problem isn't solved.. I'll choose another brand! It îs unqualified to send The laptop to the service and they make you pay for a new battery (destroyed by Asus Power management fault) and the problem didn't solved...

enriquecs2005 wrote:
Maybe Blake can tell as if the new version of bios 312resolve the problem. Marioss didn't feedback... Come on Asus don't disappoint us... I'm really an Asus fan but if this problem isn't solved.. I'll choose another brand! It îs unqualified to send The laptop to the service and they make you pay for a new battery (destroyed by Asus Power management fault) and the problem didn't solved...


I paid for the new battery the first time but still the same problem and now the notebook is for the second time to the service In italy Milan, i hope they will solve the broblem or a will contact a lowyer to see what i can do.

I was an Asus fan ......

Sergio8903 wrote:
I paid for the new battery the first time but still the same problem and now the notebook is for the second time to the service In italy Milan, i hope they will solve the broblem or a will contact a lowyer to see what i can do.

I was an Asus fan ......


probably it will tell to send to HQ center for do some experiment as for me... i honestly refused, can't waste again time for nothing, when he have precise info about the problem i will send..

gieffe22 wrote:
probably it will tell to send to HQ center for do some experiment as for me... i honestly refused, can't waste again time for nothing, when he have precise info about the problem i will send..


To be frank, it's ridiculous that Asus is requesting you to send your own laptop for testing. They are the vendor! they are supposed to have test laptops and diagnostics tools to replicate the issue. I used to work for a multinational company that is a competitor to Asus, we would never ask a customer to send their laptop for "testing" purposes. We collect logs related to the issue, in this case, battery and power management, do the proper diagnosis, verify the root cause of the problem, and either come up with a patch or an action plan to resolve the issue. What Asus is doing is just lousy support which is unacceptable for a laptop that costs $2500!

Blake1
Level 9
Hello Sergio8903,
Thank you for providing the information.
When did you send the device to service? I really hope I can catch it and solve your issue.

Blake@ASUS wrote:
Hello Sergio8903,
Thank you for providing the information.
When did you send the device to service? I really hope I can catch it and solve your issue.



Hello, the notebook is still at the service of Milan now from 1 week.

This is the second time I send the notebook, the firs time 3 month ago the service of Rome change me the battery for 62 euro because it was damage and the battery hace only 1 year of warranty, but the problem still there. So I decide to resend another time, and is 1 week that the notebook is at the service of Milan