cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Strix G814JI keeps on freezing with blinking orange battery light while plugged in

warev
Level 7

Recently bought an ROG G18 laptop however it's completely unplayable 5-15 min. into the game the laptop completely freezes and becomes unresponsive while there is a blinking orange light. This happens when gaming while plugged in. Tried to game on battery and it runs smoothly.

Things I have tried so far:

Edit power plans/options

Update drivers

Uninstall/Reinstall drivers

Uninstall/Reinstall Armoury Crate

Factory Reset PC via Windows settings AND ASUS Cloud Recovery

Clean install Windows 11

Nothing fixed it still having the same problems over and over.
Video posted for reference (this is when I clean install windows 11 while updating drivers and ms store apps)

276 Views
4 REPLIES 4

Hari_Honey
Level 7

Same issue 

DontTaseMeBro
Level 9

Blinking orange usually means there’s an issue with charging or power delivery. This could be the power brick not receiving enough power to run properly, or possibly a battery calibration issue. A few things you could try is a hard reset: shut down, hold the power button till the laptop turns on and off, then keep holding for 30 more sec.

Or a battery recalibration: drain the laptop on battery till it shuts down completely, then charge it all the way back up.

my guess is likely the later, as this is pretty common on new computers that people leave plugged and never allow it to drain fully, which can lead to calibration issues.

If neither of those work and your outlet is providing the correct amount of power, it might be worth a try to contact customer support. 

Also might be the power adapter itself. The troubleshooter in myasus has a power adapter test. It’s just labeled adapter.

Saviant0
Level 9

I have been having this same exact issue with the same exact model until some weeks ago but on startup, on mine being on battery or not did not matter. Sometimes battery light on startup would start blinking orange and fans started to spin up. The PC would not boot no matter what, if I do not hold down the power button for 20-30 seconds (a normal button shutdown was not enough) and then power it back up, in this case this always fixed the issue. This was so frustrating but it disappeared by itself now. I've never seen this issue repeating until then. I don't think that I installed a major update while this issue was occuring but I see that there is a new BIOS now (V325), maybe you can try that and let us know if that fixes your issue.