cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX G531GW Black Screen Problem

McCoolitz
Level 7
I bought a Laptop, ROG STRIX G531GW over a month ago and I'm randomly expreriencing this black screen. Sometimes the lower part of the screen will become black and the remaining part will gradually decrease in brightness until whole screen is dark. The keyboard light is still on and screen will not turn back on whatever keys to press. After doing hard reset, the computer will boot up normally and the screen is good again. Last time I exprerienced this fault was the whole screen just gradually decrease in brightness until whole screen is dark. After I restarted, it boot ups normally but the screen is flickering and it also disappear after a few minutes. I already brought my laptop to the ASUS service center and the technicians didn't find anything wrong with the hardware according to their diagnostic tool and even charged me 1500php because they said they installed new OS which I contested at first because it's a new laptop and recovery for the OS is also installed in the hard drive. But after 2x checked at the service center and they can't find any problem at all, I'm still experiencing this random black screen. Does anybody have an idea about this problem? Thank you.
4,930 Views
6 REPLIES 6

Sydneyblue
Level 7
I have you tried reformat ? Or DDU GPU drivers ? How old is it ?

Sydneyblue wrote:
I have you tried reformat ? Or DDU GPU drivers ? How old is it ?


I tried first to update all GPU drivers to latest version then I will see what will happen. This black screen really appears randomly so it's hard to diagnose what is really faulty. And when I leave the PC idle for long time, it will hang. I'm nor sure right now if it is caused by hardware or software fault.

I Have an update about my laptop. The black screen problem still exist. When it happened one time, an external monitor was connected via the type C display port. The computer screen slowly goes dark but on the TV screen the image is still ok. But the computer was also frozen and I couldn't move the mouse. It is weird that sometimes the fault will appear for several times when it happened and also the fault will not appear for several days or weeks and the laptop seems ok. It also happened when I leave the laptop in idle for several hours that I couldn't wake up the screen anymore. Is there anybody from ASUS or anyone who have an idea what could be the problem? My laptop is only 2 mos old. Thank you.

Blake1
Level 10
Hello McCoolitz,
I think there is something wrong with the panel hardware.
If would be very helpful to diagnose the issue if there is a video, but I know that it's a bit difficult.
So let me consult more, and please kindly try on the video as well.
Thank you.

Hi,

I know this thread is about a year old but I too have had the same issue from around the time I purchased my ROG Strix G531GV gaming laptop in July 2020. Although I don't have a video, I've attached an image of how the screen fades here(happens exactly as OP describes it). You can see a sort of rainbow line across the middle of the screen, like drawing pixels to the screen stopped midway.

When I contacted Asus support, they initially suggested that I update my Asus System Control Interface from v2 to v3. However, this didn't really make the issue go away. As mentioned by OP, the frequency of the issue is totally random from what I can tell(several minutes apart to several weeks apart).

It would be great if someone could offer some insight into the issue.

Roku7 wrote:
Hi,

I know this thread is about a year old but I too have had the same issue from around the time I purchased my ROG Strix G531GV gaming laptop in July 2020. Although I don't have a video, I've attached an image of how the screen fades here(happens exactly as OP describes it). You can see a sort of rainbow line across the middle of the screen, like drawing pixels to the screen stopped midway.

When I contacted Asus support, they initially suggested that I update my Asus System Control Interface from v2 to v3. However, this didn't really make the issue go away. As mentioned by OP, the frequency of the issue is totally random from what I can tell(several minutes apart to several weeks apart).

It would be great if someone could offer some insight into the issue.


Hello,

Sorry about the very late reply because I'm not very active here recently. I took a video when the problem occured and showed it to the service technician at the service center. I think they found a hardware problem. My laptop is now fixed since then. The only problem left is the CPU temperature that goes up to 95 degrees when playing games. I researched that this model only uses an ordinary paste and not liquid metal so in the next days I will try to replace it with carbonaut and kryonaut since it is already out of warranty. Cheers.