cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX G531GT Wifi adapter disappreaing again and again after win 10 update.

Anonboss
Level 7
My story : i recently buy a laptop from flipkart . laptop work excellect for 10-15days i found no problem . than i start getting updated of win 10 i update it after that i started facing wifi issue it suddenly disappread when i restart it again comes up , i try to enable disable adapter that doesnt work for me only restart always work but again problem arsing and now even after restart wifi adapter not working . i tried to use Myasus software it show 1 problem in driver but i click on check it show its up to date .did any one face any wifi disappread issue . sometimes its automatically come if anyone know how to fix kindly help me out . :confused:

These are some images of my problem






after clicking on update see the below pick its says up to date ..



Please help me out ...
4,123 Views
11 REPLIES 11

fabicus2017
Level 7

fabicus2017 wrote:
Fallow this tread and you will be fine.;)
https://rog.asus.com/forum/showthread.php?118879-Strix-G531GT-network-adapter-stops-working-when-gam...


this not gona help that i am sure.....asus laptop are shiity now...i will never buy... i will go for acer...


I found a way to solve the problem, uninstall OneDrive and Skype or disable them running in background.

The problem occurred again after few months. What I did to solve this problem is uninstall the driver and reinstall a new one.

1. Download the "Intel Wireless LAN Driver" from the ASUS support website. https://rog.asus.com/laptops/rog-strix/rog-strix-g-g531-series/helpdesk_download
2. Right-click the [Windows] icon on the left of the taskbar, then click [Device Manager].
3. In the Device Manager, click [Network adapters]> [Intel Wireless-Ac 9560 160MHz]> [Driver] tab> [Uninstall device]> [Uninstall the driver software from this device]. Then, repeat this process with [Bluetooth]> [Intel(R) Wireless Bluetooth(R)].
4. After that, open the downloaded driver from step 1 and run it.
5. Restart your PC.

The problem occurred again after few months. What I did to solve this problem is uninstall the driver and reinstall a new one.

1. Download the "Intel Wireless LAN Driver" from the ASUS support website. https://rog.asus.com/laptops/rog-str...pdesk_download
2. Right-click the [Windows] icon on the left of the taskbar, then click [Device Manager].
3. In the Device Manager, click [Network adapters]> [Intel Wireless-Ac 9560 160MHz]> [Driver] tab> [Uninstall device]> [Uninstall the driver software from this device]. Then, repeat this process with [Bluetooth]> [Intel(R) Wireless Bluetooth(R)].
4. After that, open the downloaded driver from step 1 and run it.
5. Restart your PC.

KorosuKivy
Level 10
Anonboss wrote:
My story : i recently buy a laptop from flipkart . laptop work excellect for 10-15days i found no problem . than i start getting updated of win 10 i update it after that i started facing wifi issue it suddenly disappread when i restart it again comes up , i try to enable disable adapter that doesnt work for me only restart always work but again problem arsing and now even after restart wifi adapter not working . i tried to use Myasus software it show 1 problem in driver but i click on check it show its up to date .did any one face any wifi disappread issue . sometimes its automatically come if anyone know how to fix kindly help me out . :confused:

These are some images of my problem






after clicking on update see the below pick its says up to date ..



Please help me out ...



I haven't been to keen on the rate that Asus churns out drivers, I stick to using this.
https://www.intel.co.uk/content/www/uk/en/support/intel-driver-support-assistant.html


On that note check your driver there was an advisory out on the 11th this month about the software having an "Escalation of Privilege" vulnerability https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00355.html if your driver is older than 21.40.5.1 you should get it updated

If the Device Error code is 10 fabicus2017 has a good plan on getting your wireless unit back on track again. Follow that link however if you feel you're not able or don't have the ability to do this yourself I Strongly suggest going through Asus support to get an RMA (If you have exhausted the re/installing drivers)

I have same problem as yours. My device is G513GT too. The Wfi connection automatically turns off, and the only Airplane mode remains, so I use a cat5 cable to access to Internet.
I hope ASUS could solve it quickly. I don't want to bring a cat5 cable outside.

Leo Lim wrote:
I have same problem as yours. My device is G513GT too. The Wfi connection automatically turns off, and the only Airplane mode remains, so I use a cat5 cable to access to Internet.
I hope ASUS could solve it quickly. I don't want to bring a cat5 cable outside.


my laptop is in warranty so i claim it ....they saying they will come at home within 2 working days...and today is 2 day only ... 23 sept 2020

Robert0213
Level 8

I have got rid of the issue by performing cleanup of network devices.