cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Strix G531GT high temps

Mitu_Vlad
Level 7
Hello, I have bought this laptop in october 2019 and I've had a few problems with it. First the unit that i initially bought was dead. After it has been replaced I had no problems with it for a few months. It has 16 gb of RAM, an Intel Core i7 9750h and an Nvidia GTX 1650. So as I was saying after it has been replaced I've had no problems with it and i was able to play games at really high settings with 60 fps no problem. After a while one of the fans has broken down an I had it replaced. Now I am experiencing really high cpu temps when playing games. Somewhere around 90-97 C even if the cpu isn't at 100% usage. Also a few BSOD's have happened probably because it got way too hot and it had to shut down. Idle temp is around 44-60 C. Question is should I send it to someone to check it out or is this normal? Also I tried undervolting but I can't manage to do it. At least not to a point where it is stable and it has an impact on the temp.
830 Views
5 REPLIES 5

AtGrigorov
Level 10
First thing - repaste it. Second - try to undervolt it properly. 185 offset for Core and 85 for Cache would be good (works best in my case).
Factory pasting is basically crap. Choose proper paste with high working temp and apply it very thin and even. Tighten the screws in the proper way, according to numbers on the heatsink. I had to make several attempts, until finding the proper paste and application method. Before it was constantly thermal throttling. Now temps are almost never exceeding 90 C and no warning appearing in TS's Limit Reason box. Do some test with Cinebench 20 and TSBench to check your settings. No warnings should light in yellow or red during tests and no errors should appear in TSBench.

All right. I will try to repaste it see if anything changes if not I am going to try undervolting again. Hopefully i will be able to fix it. Thanks for your response!

For best results, do both - repasting and undervolting.

So, I have a problem maybe you can help me. I opened up my laptop and saw that the fans were full of dust i cleaned everything i could, i also repasted and now i tried undervolting. Before i posted to this forum and after i failed to undervolt the first time i updated my bios to version 307 thought that might help. Now I can no longer undervolt; the sliders in xtu are greyed out and locked. I am pretty sure that it's because of the bios update. Is there anyway that I can go back to 305?

I found this but i can't find the image for 305 and also they are talking about a different laptop and i don't know if i should do the same in my case.
https://zentalk.asus.com/en/discussion/29744/how-to-rollback-bios-version-of-asus-zenbook-pro-duo-ux...

Blake1
Level 10
Dear all,
Please refer to below notice from Intel
https://www.intel.com/content/www/us/en/support/articles/000055804/processors.html?wapkw=SA-00289
We will follow this by BIOS update for all model affected.
Really sorry for any inconvenience caused.
Thank you for your continued support and patronage.