cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX G18, G814JU-N5048 not booting.Only keys lights up,but screen is black,no CPU activity

StefanPopescu
Level 8

Good day everyone!

 

I just bought a new ASUS ROG G814JU-N5048. I bought it on 5th of July and on 10th of July it stopped working. As I press power button, RGB keyboard lights up, and thats all it does. Screen is black, no apparent CPU activity.

Already tried the following:

- Removing battery connector from the motherboard, trying to start it only with AC adapter, nothing

- CMOS reset performed by ASUS instructions (holding power button pressed for 40 seconds...nothing

- removed all RAM cards and tried them individually in each slot, nothing,

- removed the SSD, nothing.

- removed the USB plugs board, nothing.

it does a funny thing, when i power up on AC power, it shuts down as I plug the adapter out. Should not remain ON because of the battery? Also, when I power up on battery only, it shuts down when I plug in the AC adapter. Again, funny behaviour as it should not matter, right?

All processors (integrated, I9 and GPU) are cold, sign that they dont work. Coolers are off all the time.

After doing a bit of research on the internet, it might be a faulty motherboard...a shorted MOSFET or capacitors.

If anybody knows how can I find the PN of the motherboard without removing it, and maybe a vendor I can buy it from, would be great, since the store will not refund me and the third party companies ASUS uses for repair are literally useless (only bad reviews).

Thanks and regards

Stefan
3,782 Views
10 REPLIES 10

BoDiE2003
Level 9

I had the same issue, in my case worked powering on without power AC adapter plugged in, on battery. 
In some cases had to press ESC key too.

Give it a try

Hello and thanks for the advice. Tried that already, no success...

KostiantynG
Level 8

I have the same problem ASUS ROG Strix SCAR 18 G834JZ (G834JZ-N6020)
Video link:
https://youtu.be/mX1G8aZotZ8

UPD: I changed KF548S38IBK2-64 to KVR48S40BD8K2-64 and it works Fine! https://www.kingston.com/en/memory/search?partid=KVR48S40BD8K2-64 Not booting. Only keys lights up, but screen is black. G834JZ with KF548S38IBK2-64 RAM Kingston FURY Impact 64 GB (2 x 32 GB) 4800MT/s DDR5 CL38 SODIMM - ...

https://www.asus.com/support/FAQ/1014276
 I disconnected the hard drive, memory, and battery. I tried resetting it by pressing the power button. Then I connected everything back. I closed the lid. And some combinations of turning off the power, disconnecting the battery, and pressing the power button worked.
 Perhaps the problem was related to updating the BIOS. Version 317. My update was successful, but Windows only loaded in recovery mode. Look at the articles that describe the problems that arise after the update.
 Previously, I changed the RAM and added a hard drive. But after that, everything worked until the installation of the Windows 11 update, and along with the updates, the BIOS was updated to version 317. After that, there were problems loading Windows, and after several reboots, the black screen.

PXL_20230730_112513852.jpgPXL_20230730_124430190.jpgPXL_20230730_142513353.jpgPXL_20230730_142522293.jpgPXL_20230730_142543548.jpgPXL_20230730_142545747.jpgPXL_20230730_142548447.jpgPXL_20230730_142553217.jpgPXL_20230730_142603997.jpgPXL_20230730_142616751.jpgPXL_20230730_142634809.jpgPXL_20230730_142640705.jpgPXL_20230730_142645936.jpgPXL_20230730_142654312.jpgPXL_20230730_142718285.jpg


Thank you for your reply.

In my case, I managed to send the laptop back to Romania (country where I bought it from) and they replaced it with a new unit. I dont have the new one yet, did not have the chance to give it a try yet.

So, you are saying that we should avoid updating the BIOS to version 317.

I cant fully understand your final sentence....could you recover from the black screen eventually, or not? if so, how did you do it?

I am from Ukraine and I use a translator to communicate.
After updating the BIOS to version 317, Windows stopped loading:
https://www.reddit.com/r/ASUSROG/comments/15cojjo/rog_strix_scar_18_g834jyn6035_after_bios_ver_317/
Black screen after several reboots.
I used the instructions:
https://www.youtube.com/watch?v=18-lOq1XQiA
But in my case, turning off the built-in battery and resetting it according to the instructions helped.
After the reset, the bios loaded. Next, reinstall Windows

When reinstalling, you need to add the Intel Rapid Storage Technology (IRST) drivers:

https://rog.asus.com/ru/laptops/rog-strix/rog-strix-scar-18-2023-series/helpdesk_download/

https://dlcdnets.asus.com/pub/ASUS/GamingNB/Image/Driver/Chipset/30499/VMD_ROG_Intel_J_V19.5.1.1040_...
run the exe file on another Windows computer and transfer the files to the installation USB flash drive.

KostiantynG
Level 8

KostiantynG
Level 8

Now the laptop is running on BIOS version 317. I reinstalled Windows. It seems that there are no more problems. Recommendation: before updating the BIOS, check the information to see if there are problems with the new version.

KostiantynG
Level 8

)