cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Strix G15 513RM laptop missing keystrokes

WWooka
Level 7

Hello there.

 

I've been having a keyboard issue for a long while now and it is getting really frustrating. Sometimes when I am typing, my keyboard tends to skip a letter while I am sure I actually pressed it. For example when I type "Google", it shows "Gogle" and missed a letter o. This happens every like 2-3 sentences. I am sure I am not typing anything wrong. It happens with all the letters on the keyboard so it's not that one specific key is broken or something. Sometimes my keyboard is just typing fine without this happening, but then suddenly it skips a letter again.

 

Sometimes it also double types a letter while having it pressed once. And sometimes it switches up the order of the letters typed.

 

I know that it's a very specific issue I can just try to ignore, but it really pulls down my productivity. I have to go back to so many words to correct them. It's just very annoying.

 

The weird thing is that when I attach an external keyboard that the problem doesn't occur anymore. I also never spilled anything on my keyboard. I maintain my keyboard weekly and make sure there's no dust and filth on it.

 

My laptop is only 1 year old.

 

What I already tried and did not work:

 

- Updating windows to latest version.

- Purchased DriverEasy to update all drivers.

- Uninstalled ArmouryCrate.

- Disabled touchpad.

- Disabled filter and sticky keys.

- Ran safe mode to check keyboard.

- Enterd DISM commands in cmd.

- Ran the keyboard troubleshooter.

- Did bios update.

- Contacted Asus support chat multiple times, also mail multiple times.

- Updating/uninstalling keyboard drivers in Device Manager multiple times.

- Chatting with Microsoft support more than 5 times.

- Doing a Windows reset 2x.

- Did a full factory reset twice.

- Sent my device in for RMA and still not fixed.

- And probably more small things I tried to fix it, but none of them worked.

 

Is there anyone out there that can help me please? I would really appreciate it.

305 Views
3 REPLIES 3

Me_
Level 7

Type Services.. run as admin.

Find ASUS

ASUS Link Near

ASUS Link Remote seems to be buggy for me on keyboard stroke lag. (If this helps you).

I have tried to disable and turn off these two services but they keep magically comming back on. Finally I just turned off all the ASUS findings..

ASUS App Services

ASUS Software Optimization

ASUS Switch

ASUS System Diagnostic. 

As you see in the photo, they are all turned on. Yesterday I noticed keystorke missing and slight lag. Once again, these are ' magically ' turned on after I went in and turned each one off. This to me is 100% spyware. 

I have removed MyASUS and AMD software on a fresh install of windows, yet windows update put in Armoury Crate Interface. I game every day with 3060 gpu and have no issues.. ( but the game is CPU intensive ). 

I hope that helps. 

Me__0-1699810518339.png

 

Also, turn off Bluetooth when doing these, turn on and see if one of those AMD services starts, keep an eye on those services.

 

WWooka
Level 7

Hey @Me_, thanks for you answer. I tried running Services in administrator mode and disabling the services you told me, yet I have the same issue. Do I need to uninstall MyAsus and AMD Software too just like you did? I tried this with bluetooth turned off.