cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog G16 not giving display after bios update.

ramenez1
Level 7

My friend has latest Asus Rog G16, there was a bios update and he updated it and left the laptop to update. When he came back the laptop was off.

When he presses the power button, the RGB of laptop and keyboard light up but the screen is absolutely pitch black. Nothing comes on at all. Literally nothing, and after a while the laptop shuts off itself, after couple of minutes.

What could have gone wrong here? And how to fix it?

461 Views
9 REPLIES 9

diegoop
Level 7

Hi mate, I had this same exact issue today (found your post looking for a solution). And just got mine working by doing an EC reset. This is done by disconnecting the charger, and pressing the power button by 40 seconds, in the process the computer tried to start and went off again after 10 seconds or so. Once the 40 seconds passed, I released the button and turned it on. Took a bit to start but finally went through the boot process with no issues.

Hope you can get it fixed as well!

Jelski
Level 9

I'm having this issue now.. But the reset doesn't work.  I boot this laptop so many times and reset so often. But no bootlogo appears. Any other solution available? 

Yu1990
Level 7

日本から失礼します。私も同じ問題が発生しました。ramの増設はされていますか?私の場合は元々付いていたramに戻したところ正常に動作するようになりました。

Flo
Level 11

Hi,

When doing a bios update on a laptop, don't touch the laptop whatever is happening for 5 minutes to be sure to not interrupt bios update process.

Here is what happening when updating bios 325 to 328:
1: bios flash reach 100% state, then the laptop reboot but there is absolutely no light, no sound, no fan so it seems to be powered-off (but it's not!).
2: about 30 seconds later (don't remember exactly but it seems quiet a long time to wait) the laptop is powering on by itself, but the screen remains black (it seems stuck, again seems long time)
3: and again after some time the laptop will reboot again and Windows will start normally.

As you can see this is a long process and I think your friend did press the power on key between step 1 and step2.

DontTaseMeBro
Level 9

Bios updates get stuck on these newer laptops from time to time for whatever reason. I've owned two asus laptops, and both have gotten stuck after the update installs and the computer reboots to a black screen and lit keyboard, but you need to make sure it's actually stuck. There's a retraining process after bios installations and it's normal for it to take a bit to post to windows. You should give it about 15-20 min before doing anything because most of the time it will resolve itself. If the computer has sat for a bit and nothing has happened for that amount of time, it's fine to go ahead and do a hard reset in which you unplug power and hold the power button for 40 seconds. You need to hold it till the computer shuts off, then keep holding it. I've had to do it several times and it's worked out just fine, the system should take a minute to retrain (black screen/lit keyboard) then post into windows.

Goodday, 

I have been doing this during the weekend even disconnected the battery check the cable connection to the battery. But it just won't boot. After maybe an hour orso the fan start spinning though but nothing happens. Spend like 8nhrs on arrival. Day getting the laptop as i want. To find out next day it won't boot anymore.

Try this:

1:Unplug battery 

2: while battery is disconnected, press the power button for at least 40 seconds.

3: plug the battery

4: press power button

Didn't work for me.. Asus will try to send me unit number 3 this month . I had contact today with Asus and they are stunned too how much bad luck I have. My 2nd unit was running perfectly on Friday and in Saturday first boot of the day the bios didn't load anymore. And then to make things better my dog was put to sleep today. 

diegoop
Level 7

IMO, If this actually is a long process as @Flo says, and there are so many ways to mess it up, there should be instructions of any kind anticipating the users how long the wait will be.