cancel
Showing results for 
Search instead for 
Did you mean: 

Asus GL553VD USB3.0 issues :(

guidorivas
Level 7
Hi there, i'm here to check if anyone had or is having the same issue as i am with the ROG laptop. Making a long story short, usb 3.0 ports won't recognize usb 3.0 devices. As in:

Usb 3.0 ports (2x left): wont work with 3.0 devices but works fine with 2.0 devices << edit: they do give POWER tough
Usb 2.0 ports (1x right): will work with both 3.0 and 2.0 devices, but at 2.0 speed of course.

It seems to be a problem with the usb 3.0 host controller provided by windows 10, and reinstalling port io and chipset drivers won't solve any problem. I tried a lot of things as listed below:

- Upgrade AND downgrade Bios (currently at v304 but i was at v307)
- Tried using different usb host controller drivers but didn't find any that work other than the OEM windows one.
- Tried uninstalling disabeling and reinstalling multiple times the drivers and had some succes (will explain later)
- Tried booting on ubuntu live cd and it doesnt work there either!!

The thing here is that i know that the ports work at 3.0 speed, because if i uninstall shown and hidden usb devices, and host controller, and try a combinations of reboots and reinstalls, sometimes i get the devices to show. As soon as i unplug them and plug them back again, they stop showing.

It is as if the first usb3 devices will stall the usb controller host or something.

The windows version is 1809 but, as i was surprised too, ubuntu won't recognize them too so i thing its a software/hardware relationship issue.

I really don't know how to get it to work, i would like to try a factory restore but f9 key process wont work on mi ROG.

Any ideas?
tnx!!
3,719 Views
2 REPLIES 2

moses0101
Level 7
Idk if this will help you or not, but try to plug your USB device deeper.
I have this issue bf ( when the first day i bought the Asus ROG laptop) later on i updated all the drivers and still didn't work. Later on , like 2 days after I use my laptop, I try to plug the USB deeper , what i mean deeper is like really deep (u need to push it to the end), and it works for me.
You could try it , if this method does not help you, and you already updated all of your drivers included USB port one, try to get a fix at asus center.
sry for my bad english btw:(

vjdato21
Level 7
Try removing ASUS USB Charger Plus, had the same problem too with my GL553VW, then I removed it, then things are now working well.