Showing results for 
Search instead for 
Did you mean: 

Asus GL503VM Bios admin password problem

Level 7
Hello friends! So recently i bought GL503VM already used. I used it for few days then i wanted to go into bios, and i saw that bios is set with admin password, which i have no clue. So now i can only go into bios as USER, and in that way i cannot change any settings so its useless.
I checked in google many ways to reset that admin password, but failed in all of them. There is it what i tried:
- Removing CMOS Battery, and laptop battery, Draining all the power. But only Laptop Timer resets nothing else.
- Few Software programs which didnt do anything
- Recovery Password (when i enter in bios and it asks me for "PASSWORD" i CANNOT get into recovery password with ALT + R , just nothing happens even when i put a wrong password and try again, that message for recovery password never appears, and after 3 fails its locked and i must resset laptop again.
- Changing date and time back to 2002/01/02 and not only that date i tried with many, still nothing happens and cannot go into recovery password
- Tried few common password nothing works
- Contacted seller, but he has no clue what the password could be, maybe he set it when he bought the laptop and he dosnt remember so thats not an option

Any other clues? I really want to remove that bios password and its saved probably in EEPROM of laptop, but im not that good to buy some tools and hack it up, will be grateful if you help me! Thanks!

Best regards

Level 11
Return for refund!

Level 7
Not an option, its bought from marketplacae 3 months ago, not from ebay