Showing results for 
Search instead for 
Did you mean: 

ASUS G74SX - Problem with video drivers

Level 7
Hello everyone, I will try yo keep it short, and hope that anyone here can help me out because I have this issue with my ASUS G74SX for quite a long time.

Not a long time a go I decided to change my hard drive, because of that I didn't have anymore the partition system with the system backup restore, at that point no big deal drivers are available at the download section on the website, everything went ok however since then I'm experiencing incompatibility with software that I didn't have before related with the video driver.

Such as "Video Card not supported" while trying to use a 3D application or "insufficient onboard memory video" what is this issue related to? I've been talking a lot with tech support of "LumenRT" a 3D software that I use for presentations and they told me that the software detects a second video onboard and that might be the problem, I've tried all, updated BIOS, uninstalled drivers, update drivers, update software, almost everything but nothing seems to work. At last I gave up and decided to blame LUMENRT because of their lack of tech support to fix this issue, but today it happens that I decided to play an old game that I liked SWAT 4 and surprise a windows pop up shows up saying insufficient onboard video memory. WTF seriously I know its an old game and is way outdated but it's too much coincidence.

There is a problem regarding CERTAIN 3D applications, I have tried battlefield 3 and resident evil 5 with no problem. I have tried directly from nvida control panel to use those applications with the current video, I have tried all and nothing seems to work.

Please anyone I don't care about gaming I use this laptop for work and I need to make my software to work back again, because it worked before i changed the harddrive.

If someone have answers to this simple questions will be great

1.- Does the Asus G74SX come with other video chip onboard? (current is GTX560m)
2.- Is there any issue maybe specified in other thread regarding to this issue?
3.- Am I missing an installation app that specify in any kind a solution to this?

Many thanks