Showing results for 
Search instead for 
Did you mean: 

Another Briked G75

Level 7
I know there's a lot of post about bricked notebooks who update their BIOS. I'm here just to ask some questions and cry a little. First, my note is stucked in the black screen, but the backlight of keyboard is responsive to Ctrl+Home function, the lights indicators works, so i don't know if this is a full brick.

To the questions. First, the Ctrl+Home+Power combination resets the BIOS defaults or just enter in EZFlash ?
Second, is there any internal batery in G75 ? I opened the HD section and couldn't find anything.
Last, holding the power button ,after removing the battery, clear the CMOS ?

Now the "cry" section. Really, i'm almost giving up to this. I brought the note outside my country (Brazil), and choosed ASUS to not have a headache with problems because i trusted the brand. But now, after less than a month this happens.
If this is a problem with notebooks who were updated with WinFlash (like me), and after so many problems with this, why the WinFlash is still in the downloads sections ?

I'm now waiting for a response of ASUS support center to see if there's any assistence in my country (i don't think so).

1 less client of ASUS.

Sorry if i talked any crap. I'm too frustrated. 1500 dollars in a black box.
162 REPLIES 162

Level 7
i tried the ctrl home key button but keyboard lights just stayed on and still black screen..

Yes it doesn't always work, the G75.bin file on the root of your C:\ drive has to be there and intact.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro

US Customer Loyalty Agent
Clintlgm wrote:
Yes it doesn't always work, the G75.bin file on the root of your C:\ drive has to be there and intact.

If you are still using the original ASUS Windows image, it should have the G75.bin file already there on the C: drive and you should be able to see it if you want to go through the trouble of connecting your hard drive to another computer by USB although you need to change the settings to show the hidden files.

Otherwise, it will take more work to set it up and may still not work.

Level 7
Thanks for the help guys!
I bought the BIOS chip (Winbond W25Q64FV) and the programmer for the chip.
I have also unable to extract the chip from the motherboard.
The problem now is that I need the correct BIOS file to write to the chip before soldering it back on the board.

Can anyone tell me where I can get this file?

PS. Did I the extraction of the file from my original chip, but it looks like the top of data is corrupted and BIOS files provided on ASUS website there is a difference of less than 2MB.

i had black screen after trying to clone ssd from a hdd.
I suffered a power loss during process.
I tried to install the possibly cloned screen !!
..tried to reinstall old previously good hdd screen !!!!!!!!....
i went round and round in panic ....just in case i was missing something
..... then I decided to take out the extra ram Id just fitted before doing the ssd upgrade
... and hey presto the hdd booted back to life 😉 ...... thing is id ordered the exact ram that Hwinfo64 identified
HYNIX HMT35156CFR8C-PB X2 BANKS OF 4GB but they sent HYNIX HMT451*********** as a compatible upgrade

refitted the new screen.....took it out ...... all good .....
point is when you open up the top 2 decks of ram are easy to knock... just saying ....You could check that your ram is in good and its good ram !!!

Level 7
Hello there, Guido7142 i have exactly problem,can u help me to resolve step by step? (Im from Brazil)

Level 7
bad luck, already changed the bios... buyed at ebay seller and changed about 1month of wating when, posted that solution my mb was already clean waitng for the new bios...

and it worked, 1st try... ok

Level 12
You just need to use this to get your keyboard lights working again (follow the guide in there for setup). Special thanks to Gary Key.

EDIT: compatibility/success

It works for G46's
It works for G55's
It works for G75's
It works for G750's
It works for G751's
(haven't tried on G752's)

If your descriptor region is already unlocked and the BIOS security configuration settings are all disabled (chipset tab), you should be able to use FPT to do a full BIOS dump/flash; Easy Flash BIOS recovery sees .BIN extensions.

Level 7
Hi all,

I am having the same problem. My G75VW was working fine. I decided to upgrade to Win 10 and install a new SSD, after Win 7 support was discontinued.

I put the new SSD into the main slot and ran the Win 10 install from a USB stick. Everything went fine. I was able to restart the computer many times with it booting into Win 10.

Then, I basically wanted to copy all of the files over from my original HDD with Win 7 over to the new SSD with Win 10, but I wanted to do it within Win 7, because I wanted to see which files I'd need and which I wouldn't need and stuff like that. I put the regular HDD into the main hard drive slot, and the SSD into the secondary slot, but when it booted up, it went into Win 10.

So I went into the BIOS and changed the boot order to get it to boot into Win 7. It still booted into Win 10. I did some more tinkering around with the boot order a few more times, and each time it booted into Win 10...............until it didn't boot into anything.

I would get a blank screen (even when attached to an external monitor via VGA and then HDMI). I could hear the fans spinning, and the CD drive would make it's sound upon startup, but nothing else. The battery would charge, and the "Charge when off" USB port would deliver power when the computer was off.

I took the computer apart, checked for any physical damage, disconnected the CMOS battery for over 24 hours, cleaned everything, but nothing seemed wrong. When I put it back together, it worked the same way it did before I took it apart. No display and no Posting after powering on, but the fans would still work and the CD drive would make it's sound upon powering on. Basically it was the same as before, but just cleaner on the inside.

I've been pouring over the forums for the last few days with no real luck. I've tried the following:

1. The Left Control Button + Home Button and then hitting the Power Button and releasing the Power Button after it turns on, with various BIOS files on the hard drive and a USB drive. No Luck.
2. The shorting out the JRST2001 and JRST2002 solder points. No Luck.
3. Putting the Recovery DVD's into the DVD drive to hope that that would trigger something. No Luck.
4. Putting the SSD with Win 10 into the main slot, and then the HDD with Win 7 into the main slot with no luck.
5. Asking it nicely to work. No Luck.

I haven't tried ordering a new BIOS chip yet, because I see that sometimes that doesn't always work, and I'd have to practice my soldering skills, but will do that if necessary. However, I don't know how to, nor do I have the tools to reprogram the chip through the API programming thing mentioned periodically. I have also seen some mixed results among people in the forums as to whether the new BIOS chip and programming actually works.
Also, the link for the file from Guido7142 doesn't appear to work anymore, so I can't even download that to test it out.

Again, before I start ordering a new BIOS chip, I wanted to clarify a few things with the community to make sure that I was doing the Control + Home procedure right.

I have the original hard drive, but I did originally upgrade from Win 7 Home to Win 7 Pro, shortly after I got the computer in 2012. But when I connect the hard drive via USB to another computer, I can view the System Reserved recovery partition, but I don't see the G75VW.BIN file anywhere on the recovery partition, or on the regular C: Drive path. Nor do I see that file on the recovery DVD's that I created when I first got the computer.

But poking around the forums, I found that you should download the original 207 BIOS from ASUS's website, extract it directly to the USB Drive and the Recovery partition, and then you can rename it to G75VW.BIN and a few other things and that that should work, but it didn't in my case.

So I was wondering if there was somewhere else that I should be looking for that original BIOS BIN file on my hard drive, or on the recovery media, because I can't seem to find it. Or if there were more specific instructions regarding what files should go where on the hard drive and on the USB stick when trying to do the Control + Home method, because I think I've been doing it right, but I'm not really sure, as there is a lot of various forms of information out there, and I wanted to make sure that I was doing it right.

I know that this is an old thread, and an old computer, but I absolutely love my G75VW. Prior to this, it was working fine, and is in good condition, and even worked fine with the Win 10 and SSD upgrade, until I started playing around with the BIOS. To the best of my recollection, I believe that I had updated the BIOS a few years ago to the most recent version with no problems. I would love to get a few more years out of this computer, since it is in pretty good condition (other than the whole not turning on thing), and I fell that it would be able to last for a few more years.

Thank you in advance for any help.

Take Care,

Have you restored your original Windows 7 Pro HD in it's original slot, remove any other HDs, boot into BIOS, point it toward the original boot partition?

Your problems started when you tried to start the laptop with two HDs with boot partitions on each.
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server