cancel
Showing results for 
Search instead for 
Did you mean: 

Another Briked G75

Jihilian
Level 7
I know there's a lot of post about bricked notebooks who update their BIOS. I'm here just to ask some questions and cry a little. First, my note is stucked in the black screen, but the backlight of keyboard is responsive to Ctrl+Home function, the lights indicators works, so i don't know if this is a full brick.

To the questions. First, the Ctrl+Home+Power combination resets the BIOS defaults or just enter in EZFlash ?
Second, is there any internal batery in G75 ? I opened the HD section and couldn't find anything.
Last, holding the power button ,after removing the battery, clear the CMOS ?

Now the "cry" section. Really, i'm almost giving up to this. I brought the note outside my country (Brazil), and choosed ASUS to not have a headache with problems because i trusted the brand. But now, after less than a month this happens.
If this is a problem with notebooks who were updated with WinFlash (like me), and after so many problems with this, why the WinFlash is still in the downloads sections ?

I'm now waiting for a response of ASUS support center to see if there's any assistence in my country (i don't think so).

1 less client of ASUS.

Sorry if i talked any crap. I'm too frustrated. 1500 dollars in a black box.
457 Views
162 REPLIES 162

mohsenslr
Level 7
I need a high resolution photo from the board . Specifically around bios chip . I think when I unsoldering bios chip , some element unsoldered and missed . In power button I have 3.6 voltage , but after press it just nothing !

Guido7142
Level 7
Oh no... that was what I was afraid of. Now you will have to scratch your brain out thinking what could you have possibly damaged from the board, be very careful because any simple manipulation of the board can damage it, not always but it is a possibility.
G75VW-BBK5 / i7 3610QM / 8GB RAM / OCZ Agility 3 SSD 120GB / GTX 660M

mohsenslr
Level 7
I sent my notebook to a repairer . Just I can't find schematic for motherboard or even a high resolution photo ! I'm very disappointed

Guido7142
Level 7
Did you sent it to an official Asus service facility ? If so, they will immediately tell you the motherboard was bad and will ask you to pay for a new one. Most big company repairers do not even seek for a problem source, they just replace parts...
G75VW-BBK5 / i7 3610QM / 8GB RAM / OCZ Agility 3 SSD 120GB / GTX 660M

mohsenslr
Level 7
dear guido7142 , i cant access to official Asus service facility.
anyway , my notebook was revived . thank you for your advise and your file . just keyboard backlight does not work . my bios version is 223 and i cant reflash it with same version . is there any solution to reflash a bios with same version ?

mohsenslr wrote:
dear guido7142 , i cant access to official Asus service facility.
anyway , my notebook was revived . thank you for your advise and your file . just keyboard backlight does not work . my bios version is 223 and i cant reflash it with same version . is there any solution to reflash a bios with same version ?


hey mohsen , i have the same problem as you, after the flash , everything works except for the backlight of the keyboard. did you manage to fix it ?

Thanks @ guido7142 my exact model no is g75vw-91079v. Can anyone upload stock bios rom for g75vw-91079v.
Keyboard light is is not working.

You can download the different BIOS from Asus Support Download I think mine started off with 206 I only updated it to through to 210, haven't found any reason to update any further and many bricked NB with 222 and 223.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro

So does downgrading the bios version help for the keyboard light issue.

Guido7142
Level 7
All VW models use the same bios. Sorry but the bios I uploaded has no working keyboard lights, do not know why but they do not work. (My G75 still has no working backlight). A long time ago I was investigating why was that and while checking if the cable was disconnected I managed to break the cable (that particular cable is so long that it must be folded at some point, it comes already folded from factory, and that part proved to be quite fragile).
G75VW-BBK5 / i7 3610QM / 8GB RAM / OCZ Agility 3 SSD 120GB / GTX 660M