Showing results for 
Search instead for 
Did you mean: 

ROG Swift PG32UQ Unable to Access BIOS

Level 7
Hey everyone, new to the forum. Recently just built a rig with Maximus Apex Z690 i9-12900k and I am using a ROG Swift PG32UQ for the monitor.
My issue is that it is impossible to access the BIOS due to the time the monitor takes to initialize. I have disabled fast boot and allowed my USB hub to stay awake. I have tried using a wireless and wired keyboard and still cannot see the Asus logo where the window of opportunity lies to hit "Del" or "F2"... it goes directly to the Windows logon screen when restarted or when powering on from being shutdown.
I have the latest BIOS for the MOBO and firmware version 0204 for the monitor.

If I switch to a generic HP monitor I am able to see the Asus logo and hit the "Del" keys and thus access the bios, but not on the ROG Swift PG32UQ.

Any feedback or help would be greatly appreciated.

MasterC@ROG wrote:
Sorry for the wait, a solution is coming, may not be that soon but it's coming.

Any update on this? It's really a pain updating the bios with the XG279Q...

darkcg wrote:
The new v034 firmware solved the issue. With it, you can disable the deep sleep state, which fixes almos every problem regarding the video signal.

Hi DarkCG,
Can you point me to where that deep sleep setting is?


Level 10
Another 2 months past. Where are you MasterC@ROG 😞 my monitor is a pain to use without Deep Sleep option toggled off and I can't do that without the firmware update.