cancel
Showing results for 
Search instead for 
Did you mean: 

ROG SWIFT PG32UQ Problem

ilchoangelov
Level 8
Hello, from 04.12.2021 I am the owner of ASUS ROG Swift PG32UQ.
I have long dreamed of this type of monitor - 4K 144 Hz and G - Sync.
To be honest, I don't understand much. I just love to play games and have a great picture 🙂 I had some difficulties with the monitor settings. Until now I used Samsung 34 "CF791 Curved (3440x1440 100 hz) and in the beginning it was a bit strange on the new monitor. But after a few hours I think I adapted. For games Asus is quite good.
I realized that in order to use G-Sync I need to use a DP cable and turn off V-sync.
However, I encounter something strange. After a while, my new Asus PG32UQ monitor turns off for a second and starts up again. Its screen turns black and loses its picture. I replaced it with another DP cable and the problem reappeared. Then I swapped the inputs of the Video Card (My video card is Asus Strix 3080Ti). So far I have not had a problem with my old monitor or this video card. I reset the settings on the new monitor, but the problem remains. I DON'T KNOW HOW TO UPDATE IT.
I don't think there's a problem with the monitor or the computer, but I don't think I've done anything right.
I will be grateful for advice.

My problems are several:
1. Why does the monitor turn off and how do I fix this problem (I'm very angry)
2. Which to choose 144 hertz or 155 hertz
3. I notice that when I start the computer, the monitor wakes up very slowly - how can this problem be fixed. Sometimes when the monitor is asleep there is no release, I have to press the back button.

Thanks in advance
2,876 Views
13 REPLIES 13

UltimateGohanSS
Level 8
1. Update to FW 024 and see will it help you
2. 144hz
3. no help for that for now.for me is slow too

Hello. I updated the monitor to FW 024. I think the colors have improved a lot, as well as the HDR. Also, when I start the computer or restart, I already see the logo on the bottom and I can load the BIOS. It seems that after the update everything fell into place ..... The monitor I use is a DP press and at 144 hertz. For now, there are no interruptions, I hope it stays that way. I think that the monitor is a very good option 🙂

ilchoangelov wrote:
Hello. I updated the monitor to FW 024. I think the colors have improved a lot, as well as the HDR. Also, when I start the computer or restart, I already see the logo on the bottom and I can load the BIOS. It seems that after the update everything fell into place ..... The monitor I use is a DP press and at 144 hertz. For now, there are no interruptions, I hope it stays that way. I think that the monitor is a very good option 🙂


ince you have managed to update I can't find a way to do it.

I connect the screen via HDMI 2, I have USB 3.0 connected and when I click on FW Update the monitor restarts and I get a failed installation.

Just the next steps for the update.
First I turned off the display port.
Second, I put the HDMI cable to the computer.
Third, I plugged the USB cable into the monitor and the computer.
And then they started the app.
It turned out the first time, without problems.

ilchoangelov wrote:
Just the next steps for the update.
First I turned off the display port.
Second, I put the HDMI cable to the computer.
Third, I plugged the USB cable into the monitor and the computer.
And then they started the app.
It turned out the first time, without problems.


That's just what I do, but there is no way.

The same problem, over and over.

What GPU do you have? I have a 1080ti.

My video card is Asus 3080 TI

ilchoangelov wrote:
Hello. I updated the monitor to FW 024. I think the colors have improved a lot, as well as the HDR. Also, when I start the computer or restart, I already see the logo on the bottom and I can load the BIOS. It seems that after the update everything fell into place ..... The monitor I use is a DP press and at 144 hertz. For now, there are no interruptions, I hope it stays that way. I think that the monitor is a very good option 🙂


Does your screen still turn off and on? Did the FW update fix the problem? It seems to be the problem with the PG32UQ model. MANY people have this problem. I purchased the monitor but havent installed it yet due to renovations in my house. Im debating on retruning it because of the amount of roblems on this monitor.

Sallyboy715 wrote:
Does your screen still turn off and on? Did the FW update fix the problem? It seems to be the problem with the PG32UQ model. MANY people have this problem. I purchased the monitor but havent installed it yet due to renovations in my house. Im debating on retruning it because of the amount of roblems on this monitor.


Well, so what you did in the end? Returned or still using this monitor? What's your experience? Is is working or are you experiencing problems with the video signal?

OMGDrAcula
Level 9
Just want to say I am having the same issue of it being slow to wake ONLY IF it is asleep for awhile. If I am at my PC and the monitor turns of it will instantly wake back up. It seems it hits a certain power state that takes ages to wake up. Firmware V024 does not seem to help with the speed of waking up