cancel
Showing results for 
Search instead for 
Did you mean: 

ROG SWIFT PG279Q Displayport issue.

singh_harman007
Level 7
As the title suggests I am talking about the PG279Q Gaming monitor, it's a new monitor I have purchased a few days ago and have had problems setting it up with Displayport. The problem is that displayport won't let me view anything above 85 hz. I have a ROG laptop as well so I assume there should be no compatibility or bandwidth issues and I am using mini displayport to displayport cable to connect from my laptop to the external monitor. My laptop has Displayport version 1.2 which should display up to 144 hz if not 165 hz.

The first day I got the monitor I was switching a lot between different (Hz) the default was 60 hz so I changed it to 85 hz and it worked then as soon as I set it to 100 hz my monitor started flickering and went black and then it wouldn't display anything at all. Upon changing to 100 or 120 Hz the monitor would go black for a few seconds then instantly come back on with default 60 Hz. I experimented like this for a few hours in order to get higher Hz but ended up with my laptop crashing and going black as well along with the monitor. Now I am not able to view my external monitor as "second screen only" unless I view it as "clone or extend display" from the laptop it works otherwise my laptop starts flickering and goes black and same thing happens with the screen.

I don't understand what could be the problem? Could it be that switching a lot has led to defected cable? Anything wrong with the monitor itself or something wrong with my system? I have also ensured that my system has updated Nvidia graphic drivers.

Please help!
517 Views
16 REPLIES 16

Dysternaut
Level 7
With the track record that model of monitor has, I'd say it's pretty certain that it's the problem.

However, the best thing to make sure, is to try and hook up another PC to it and see how that goes. Then take it from there.

Dysternaut wrote:
With the track record that model of monitor has, I'd say it's pretty certain that it's the problem.

However, the best thing to make sure, is to try and hook up another PC to it and see how that goes. Then take it from there.


Do you suggest an RMA then? Btw, the mini displayport to displayport cable that I am using is only 1 meter long, I have heard that using a longer and better quality cable might increase the refresh rates and so on.. Is this any true?

I have already tried with another PC, the problem is still there. Is there any other workaround or is the monitor simply faulty? I have heard many people complaining about not getting above 85 Hz across different forums but no real way of working it out.

Janne-71
Level 7
Have you tried the monitor with a desktop computer?

No, laptop.

Dysternaut
Level 7
The only two options, besides the monitor itself, is the cable and the fact that you have only tried laptop computers.

Have you got another cable to try? Or could borrow one? And could you possible try it with a desktop computer?

If not, I would describe the case with all you have tried, and RMA it. If it is an option at all, return it to the store and get your money back instead, and buy a new one, as Asus service, depending on location, can be an exercise in futility and frustration.

Dysternaut wrote:
The only two options, besides the monitor itself, is the cable and the fact that you have only tried laptop computers.

Have you got another cable to try? Or could borrow one? And could you possible try it with a desktop computer?

If not, I would describe the case with all you have tried, and RMA it. If it is an option at all, return it to the store and get your money back instead, and buy a new one, as Asus service, depending on location, can be an exercise in futility and frustration.



Yes I tried with another cable today but still no luck, the refresh rate keeps dropping down to default (60 Hz) and even gets stuck at 23 Hz. Up to 85 Hz works perfectly and even tried 100 Hz this evening and it appeared to work but can't go above 100 Hz that's the problem. Always wanted to try what the feeling is to use a monitor in 144 Hz 😕

No I can't try it on another system as I only got a laptop but this laptop is ROG itself and very powerful so I don't understand why you are suggesting desktop computer. Another problem I cannot view the monitor as a single screen otherwise my laptop crashes, stutters and then goes black. This monitor only works in "Clone or Extend mode" which I find to be very strange.

Yes I will RMA this weekend but never getting an ROG monitor again, I like ASUS otherwise but this was a very bad experience and especially considering its an ROG product, this time it sucked.

Janne-71
Level 7
Just a sidenote, but where did you get that amazing forum "status" indicator dysternaut (fragging frustrated). Has it been given to you or can you change it yourself somewhere? If it's given i wonder if it has different levels like other tags do.

The reason I wanted you to maybe try with a desktop computer, is that laptops can sometimes be a bit fidgetty when it comes to things requiring a lot of power, so trying a desktop would rule everything like that out. Plus a desktop would mostly have a normal displayport as opposed to mini as well. But it was a long shot anyway. I'd say it's probably 98% the monitor being faulty.

And I can only agree that Asus is not the go to brand for stuff like this anymore...

Janne-71 wrote:
Just a sidenote, but where did you get that amazing forum "status" indicator dysternaut (fragging frustrated). Has it been given to you or can you change it yourself somewhere? If it's given i wonder if it has different levels like other tags do.


Hehe, nah I configured it myself somewhere in my profile settings. Can't remember where though, but poke around in there and you'll find it...

I understand but its unfortunate I can't do that as I only got a laptop, would have liked to test it on a desktop maybe the results would have been different. So are you telling me displayport and mini displayport aren't the same thing? How are they different? I agree it is the monitor but now I feel like my gpu is to blame as well..

What brand according to you is the go brand for stuff like this, if not asus?