cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Swift can't get past 60mhz

Avenger411
Level 10
Hey!

i just bought this RoG Swift monitor that everyone's talking about. So far so good except i cannot go over 60mhz and 85mhz is super dark un-useable. My system is in my sig. There's one thing though, i have a GTX690 and it is a MINI display port, so i went and bought a "MINI display port TO display port" Could the cable be the culprit ? While i'm waiting for my Titan X i have no other choices...

so what do you think ? cable is uber cheap even if it cost me 20$ 😞 ?

thanks

Max
Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift
5,133 Views
8 REPLIES 8

Volt
Level 9
Some people on here have reported issues with using their previous DP video cable. That were fixed, when they used the one that came with the monitor. It might be your cable. Is your cable a 1.2 version? The FAQ says it needs a DP 1.2 for it to function at WQHD@144HZ.

Which DisplayPort version does it have?
DisplayPort 1.2 is required for native WQHD@144Hz support. All (GTX 650 Ti Boost or higher spec) ASUS GTX graphics cards offer this output.


http://rog.asus.com/339252014/gaming-monitors/faq-rog-swift-pg278q-27-inch-g-sync-gaming-monitor/

Avenger411
Level 10
Hey

Since my gfx doesn't output normal size display port (it has mini display port) i have to use an adapter that connects to the factory cable which connects to the monitor. I think the adapter is causing the problem but i have no way to test like i said. New gfx is ont the way but can't tell when it is going to be there. I'd really like to know if the monitor has a problem since i just got it from purolator (shipping company). Has anybody run into issues with adapters ? I shoulf say that 1440p works well it is gorgeous, gsyncs works wonders too only the 144mhz is missing and it's bugging me.

Thanks

Max
Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift

Avenger411
Level 10
Hey

Just read in another forum with guys with gtx690's that adapters do not work with this screen. So i'll just hold on to 60hz unt titan x arrives..

Thanks
Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift

Volt
Level 9
If your monitor is working normally thus far, albiet only up to 1440p @ 60hz w/gsync - then it's probably going to be fine with your new Titan running 1440p @ 144hz w/gsync.

I was suggeting that maybe your adapter cable might not be a DP 1.2. And instead be a DP 1.0 or 1.1. Like different versions of USB, that handle different data rates. They look the same, but there transfer data rates may be different.

If you still want to get it checked, before your Titan comes, maybe you can test out your monitor on your friends rig using the cable that came with the monitor? Or bringing it to a local computer store - just to test it?

EDIT - saw your new replay - Okay 🙂

Volt wrote:
If your monitor is working normally thus far, albiet only up to 1440p @ 60hz w/gsync - then it's probably going to be fine with your new Titan running 1440p @ 144hz w/gsync.

I was suggeting that maybe your adapter cable might not be a DP 1.2. And instead be a DP 1.0 or 1.1. Like different versions of USB, that handle different data rates. They look the same, but there transfer data rates may be different.

If you still want to get it checked, before your Titan comes, maybe you can test out your monitor on your friends rig using the cable that came with the monitor? Or bringing it to a local computer store - just to test it?

EDIT - saw your new replay - Okay 🙂


Hey!

😄 great minds think alike 😄
Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift

Avenger411
Level 10
Hey!

Came here to say that with the titan x i can go up to 144hz no problem. SO the adapter WAS the problem. Like others said, adapters don't work well with this screen! All good now.

thanks

Max
Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift

Iustin_Grainea
Level 7
Buy a good quality cable.:-)

Iustin_Grainea wrote:
Buy a good quality cable.:-)


Hey,

yeah well next time i'll know not to cheap on that..

Max
Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift