cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with my new ASUS ROG Swift PG278Q - Blurry text and bad quality overall

arnamide
Level 7
Hello guys,

I've been using my Swift monitor for like 1 week now. And my experience of the monitor is very good but, yesterday when i started my computer i saw some strange "color aura" around the text in Windows and all kinds of web browsers. First i thought it was my eyes, but i asked my girlfriend and she saw it aswell. I've been testing on other computers to see if it was my setup that was wrong. But they all have the same problem. And i realized that it only shows when im going at 2560x1440 @ 144hz. If im turning down the Hz to 100hz the effect is not that visable, but it's there. At 60Hz @ 1920x1080p the problem does not exist at all?

What can be my problem here? I've already tested different drivers etc..

I will try to put up an image on my problem but it's hard to get it on camera. It's almost needed to be seen with the eyes.

60hz @ 2560x1440

144hz @ 2560x1440
406 Views
184 REPLIES 184

merlin01
Level 7
Saw a YouTube video yesterday of someone showing this same issue https://youtu.be/FQLyFYFrgWM
In the comments someone says it's only the serial numbers starting with E7, E8, or E9 (July to September) that have shown this problem, and serials starting with EA or EB (October/November) haven't had the issue (yet).
The commenter doesn't say where the information came from - Sure would like to find something official on the subject.
Unfortunately, I have an E7 - July 2014 😞

MonkeyPulp
Level 7
I have an EB (november) serial and my monitor just started flickering after 2 months.

MonkeyPulp wrote:
I have an EB (november) serial and my monitor just started flickering after 2 months.

😞
So sad to hear.....
I submitted a case to ASUS support today - asking for their recommendation of a serial# that has fixed this problem so I don't get a replacement as bad as the original.
Can't believe there isn't any official word from ASUS/ROG on such a large scale failure of a supposedly high-end piece of hardware....
Amazon reviews are tearing this monitor apart....
For me, if ASUS can't guarantee the issue has been 1) Identified, & 2) Fixed, then I'll be getting a refund, not a replacement. 😞

merlin01
Level 7
Fast response from ASUS support - however it was a standard 'cut & paste' answer suggesting I should take it to an ASUS service center, or ship it to a service center, or return it to the place of purchase.
They didn't even attempt to answer any of my questions regarding a replacement not suffering the same fate.....
Quick but poor support 😞

Astrix_au
Level 7
It didn't fix it this time! It's a public holiday tomorrow and long weekend to make it worse.
ASUS Maximus VI Formula - i7 4770K - H80i - MSI R9 Fury X - HyperX 16GB Ram - 250GB + 500GB Samsung 840 EVO SSD - Benq XL2730Z 2560x1440p 144hz Freesync - Seasonic 1000w 80 Plus Platnum...

Astrix_au
Level 7
I called Asus support in Australia and I got straight through took all but 5-10 minutes and I'll have a courier pick up my monitor on Tuesday since it's a long weekend and estimated return time is 5 working days not including shipment so an extra few days.

Great support service so far!

I did call the shop I purchased from in Sydney after hearing the time it takes Asus in the States, the guys said it will be quicker to go through ASUS directly as he needs to send it to his supplier and would take at least 3-4 weeks.

Very happy I went with Asus warranty route.
ASUS Maximus VI Formula - i7 4770K - H80i - MSI R9 Fury X - HyperX 16GB Ram - 250GB + 500GB Samsung 840 EVO SSD - Benq XL2730Z 2560x1440p 144hz Freesync - Seasonic 1000w 80 Plus Platnum...

Astrix_au
Level 7
This morning the problem is gone again.

Other than that my monitor is perfect and I don't want to send it back if they get it and it's working fine or they send me one with other issue like dead pixels as mine has none.

Today is a public holiday and if tomorrow it's still better I will have to cancel the pick up.

It will come back someday though...
ASUS Maximus VI Formula - i7 4770K - H80i - MSI R9 Fury X - HyperX 16GB Ram - 250GB + 500GB Samsung 840 EVO SSD - Benq XL2730Z 2560x1440p 144hz Freesync - Seasonic 1000w 80 Plus Platnum...

ctren
Level 7
Just an FYI, my monitor has a manufacture date of January 2015 and serial starts with F1L. It has a problem, but not the same as what everyone else has seen. Half my screen dies with I guess you would call an inversion, but way more extreme than what everyone else has been saying. I can also "fix" it with an encouraging tap to the back of the panel.

Still doesn't reflect well on the quality control of this panel......

48617

When I had my issue occurring the other day with flickering, horizontal lines and blurry text I noticed only the right side of the screen had blurry text even though both sides were flickering. The text wasn't affected on the left side.

Is this monitor two screen joined together to get 1440p 144hz?
ASUS Maximus VI Formula - i7 4770K - H80i - MSI R9 Fury X - HyperX 16GB Ram - 250GB + 500GB Samsung 840 EVO SSD - Benq XL2730Z 2560x1440p 144hz Freesync - Seasonic 1000w 80 Plus Platnum...

Astrix_au
Level 7
The problem came back 😞
ASUS Maximus VI Formula - i7 4770K - H80i - MSI R9 Fury X - HyperX 16GB Ram - 250GB + 500GB Samsung 840 EVO SSD - Benq XL2730Z 2560x1440p 144hz Freesync - Seasonic 1000w 80 Plus Platnum...