cancel
Showing results for 
Search instead for 
Did you mean: 

PG49WCD - USB Port Reset Failure

mpiscitello
Level 8

Hi, I just installed a new PG49WGD monitor and it is impressive.  One "issue" I've noticed is that while it appears every USB port functions properly and the monitor overall seems to be working as expected, but on startup Windows throws a "USB device you connected to this computer malfunctioned" notice and in Device Manager under Universal Serial Bus controllers there is a yellow flagged item "Unknown USB Device (Port Reset Failed)".  I've connected with different cables and a different computer with the same result.  The weird thing is EVERYTHING seems to work fine.  Asus support initially suggested to send the monitor in, but I do not want to go through all of that hassle if this is something that is a timing/software/firmware issue that a replacement monitor would act the same.  I've tried searching for more info, but can't seem to find anything that would point to others seeing the same thing.  It does look like the USB device with the flag is somehow tied to Realtek via the Vendor ID.  Anyone with this monitor experience the same?  Would really appreciate any feedback as it is making me crazy...

1,282 Views
21 REPLIES 21

kolysion
Level 9

Dont usb on my pg49wcd, and with this issue, I won't use USB.

asusmisu
Level 8

Hi, I have exactly the same problem - except that all USB devices connected to the downstream ports of the monitor do NOT work because of the error on upstream side. I also tried everything... different cables, different computers, different USB ports etc. with no change. Also AURA Sync is not working because of the broken port.

I had to RMA the monitor - and the replacement arrived today. Guess what? Same error here! I am even not sure if they just returned my broken monitor as there is no serial number printed on the device and the "Device info" button on the DisplayWidget Center displays everything - but not the serial number (field is empty) 😞 

One thing I wonder is how DisplayWidget communicates with the monitor... I thought via USB... so at least this connection is working? Hmm...

Me al so if you have a monitor with firmware MCM103  you cannot upgrade to MCM107 he said firmware to old I am waiting for a answer the firmware is on the site now

Sorry MCM003 firmware and the hub works only on a native usb 2.0 port blank example rog strix b650e-e gaming

Me al so if you have a monitor with firmware MCM003  you cannot upgrade to MCM107 he said firmware to old I am waiting for a answer the firmware is on the site now  MCM003 firmware and the hub works only on a native usb 2.0 port black example rog strix b650e-e gaming

asusmisu
Level 8

Update: I found out that - when using the USB-C cable as (only) upstream from the computer - nearly everything works fine. All downstream USB 2.0 ports are working, AURA sync is working and you can do a firmware upgrade from version MCM003 to MCM107. Unfortunately, the new firmware does not fix the problem with the USB 3.2 upstream port, it is still broken (and therefore all USB 3.2 downstream ports not working).

mpiscitello
Level 8

Wow - I have been following your updates.  I also purchased a replacement to see if the issue was with mine, but the replacement had the same problem so I returned it.  It was manufactured in October also.  Where have you been able to get the MCM107 firmware?  Also, all of my USB downstream ports are working, but how would I know if they work at 3.2 bandwidth?  Though I may be not 100% clear on if that matters since they work...

ASUS support said to try the Display Widget software, which didn't do anything to solve the problem.

I made a quick and dirty test and at least 3.2 bandwith seems fine. One test directly from MB I/O. The other on the middle port of the Monitor. Both with a stick i had flying around:

bwtest.png

 

asusmisu
Level 8

I downloaded it from here https://rog.asus.com/de/monitors/above-34-inches/rog-swift-oled-pg49wcd/helpdesk_bios/. The monitor has 2 different kinds of USB ports, 2.0 ones and 3.2 ones. For the 3.2 you can specify if they should run in 2.0 or 3.2 mode in the monitor's settings. I also don't know how to prove if the speed is then correct...

Are you using only the USB 3.2 upstream cable or do you have connected the USB-C cable additionally?