cancel
Showing results for 
Search instead for 
Did you mean: 

PG32UCDM FIRMWARE

rikardu
Level 8

hello reps of ROG i need the firmware for testing, hdr is broken an so KVM, and i need for work if you can give me a firmware i apreciate.

842 Views
10 REPLIES 10

TMavica
Level 9

Yes. Where can I download

Its fine by me to be beta tester of firmware and report to ASUS any problem

OatmealCreamPi
Level 7

Ditto, please!  I have reported on this problem over on reddit 4 weeks ago and I am tired of suffering with $1400 garbage. 

stark19
Level 9

anyone have coil whine while the monitor is in Off mode?will be fixed in a new firmware?I need know for no return.

Jigovsky
Level 7

Coil whine is unfortunately a standard in electronics. You either hear it or you don't, even though it occurs anyway. In my case, nothing can be heard.
If you hear coil whine the only thing left is to replace it with a new piece, which may be quiet enough that you won't hear it. A firmware update is unlikely to help.

As for the firmware update it was supposed to be available over the weekend according to reddit. I understand that this announcement was an early April Fool's Day.

I am also waiting for the firmware update as a PG32UCDM owner for 3 weeks.

Ily3ss59
Level 7

I also have a bug on this screen, the red LED and the RGB behind the screen are lit but when I shut down the computer and turn it on the RGB and the LED does not light up I have to go to the screen options to deactivate RGB and reactivate it. I don't know if anyone has this problem too....

 

Option enable but LED offOption enable but LED offOption to deactivate then reactivate manually LED ONOption to deactivate then reactivate manually LED ON

Intel Core i9 13900KS / AiO NZXT Kraken Elite 360 RGB / Asus ROG MAXIMUS Z690 EXTREME BIOS 3501 / G.Skill Trident Z5 RGB 64 Go (2 x 32 Go) DDR5 6000 MHz CL30 / MSI RTX™ 4090 SUPRIM X 24G / 1x Samsung 990 pro 4TB / 1x Samsung 970 EVO 2TB / CORSAIR AX1600i 80PLUS Titanium / NZXT H9 Elite / Monitor ASUS ROG Swift OLED PG32UCDM

Hey there,

I reported this on monday last week in this thread  but apparently they already had some previous reports as to some similar issue with lighting, as you can see in the supposed MCM102 changelog.

Ah ok thank you very much I didn't see that this problem had been reported. I will wait for the update 😉

Intel Core i9 13900KS / AiO NZXT Kraken Elite 360 RGB / Asus ROG MAXIMUS Z690 EXTREME BIOS 3501 / G.Skill Trident Z5 RGB 64 Go (2 x 32 Go) DDR5 6000 MHz CL30 / MSI RTX™ 4090 SUPRIM X 24G / 1x Samsung 990 pro 4TB / 1x Samsung 970 EVO 2TB / CORSAIR AX1600i 80PLUS Titanium / NZXT H9 Elite / Monitor ASUS ROG Swift OLED PG32UCDM

Jigovsky
Level 7