cancel
Showing results for 
Search instead for 
Did you mean: 

PG27AQDM HDCP Issue?

payned
Level 7

so this is something i've never experienced before... i've had this monitor for about a week now, but every time i try watch something on hbomax or amazon prime my pg27aqdm just turns off. like i click play, and then screen goes black and says "no displayport signal". i have to restart my pc every time to get picture to come back.

the monitor is on the latest firmware, drivers for my 4080 are on the latest, using the displayport cable that came with the monitor. i found this thread where they had to plug in with hdmi once and play HDCP, to like, kick start his HDCP on DisplayPort?? havent tried that yet but seeing if anyone else had this issue?

356 Views
4 REPLIES 4

Nate152
Moderator

Hello payned

Doing a little research, setting the refresh rate to 60Hz fixed the blank screen issue for some.

Set the refresh rate in windows, then check Nvidia Control Panel.

Windows Refresh rate.png

NVCP 60Hz.png

No issues with HDCP using a displayport cable. I'm using a Silkland Displayport 2.1 cable.

HDCP.png

 

I will try this when I get home from work and provide an update

Nate152
Moderator

Great, I'm looking forward to hearing if setting the refresh rate to 60Hz solved the blank screen issue.

If it doesn't solve it, some are saying to try a different browser.

 

 

 

Alexarson
Level 7

I also face the same issue as you. For myself, it started from yesterday. Hope to get some fix soon.