cancel
Showing results for 
Search instead for 
Did you mean: 

Just purchased the ROG Swift & have a couple of queries

giggsy11
Level 7
Firstly, I love this monitor. No major issues, I was worried I wouldn’t get the best out of it with a single 780ti @ 1440p but games feel so smooth now, regardless of lower frames. Anyway, I have a couple of little niggles I’d like to get to the bottom of 

1. I have the monitor set to 120hz, not 144hz as I noticed that the GPU clocks don’t idle at 144hz, which after doing some googling seems pretty well documented, is there still no way to fix this? It’s not a major issue as 120hz still looks great and with a single 780ti I may not always get 144fps but it’d still be nice to have it on for older games/desktop.

2. I have noticed whilst testing a couple of games that the frame rate is capped at 60fps unless I press the turbo button in game and set it to 120hz/144hz, then it uncaps, but when I turn the computer off and on again it resets back. I have only noticed this issue whilst running the benchmark for Final Fantasy A Realm Reborn & Football Manager 2015, but I noticed someone on these forums having a similar issue with BF4. As far as I can tell it’s set to 120hz everywhere in the Nvidia control panel and in Windows and in the Final Fantasy benchmark there are no settings to tick or untick to uncap the FPS, also it wasn’t capped at 60fps on my old Asus VN247H. Pretty sure that the full game of Final Fantasy has options to select the refresh rate in game, so it might not be an issue when i actually play it but still strange the benchmark is capped.

Thanks.
2,936 Views
4 REPLIES 4

aeliusg
Level 7
You can fix both of your problems to an extent by setting refresh rate to highest available in global 3D settings.

giggsy11
Level 7
Pretty sure i've set all available options to 144hz.

Volt
Level 9
I run FRAPS in the background to check my FPS while gaming.

Try using the latest nVidia drivers, if you haven't already done so.

EDIT : Come to think of it, when I first got my SWFIT, I sort of recall having some minor issues with the refresh rate changing. I'll try to recall what I did. But the issue soon went away.

Deon017
Level 8
have you set G-Sync on in the Nvidia control panel?