Showing results for 
Search instead for 
Did you mean: 

Broken semi-non fuctional with no graphics on PG-278Q Monitor [Software issue?]

Level 7
So i've had this monitor for about 3 years, yesterday my powerbrick broke i've replaced it with an original powerbrick which my buddy still had at his house (from a pg278q) as he sold his one a long time ago and forgot to send the power brick... so today when i turned the monitor it took about 30 second.. i've had a black screen for and then small noise box where ROG logo should be appeared, after it i've became a menu with broken text and 2 options to choose from.. both did nothing and monitor worked.. but the menu is all broken i can't cycle through settings.. tried to cycle through 24hz,60hz,120hz,144hz, fullhd but nothing fixed it..

i can cycle through crosshair settings with the thumb-stick but can't through normal settings or the menu*.
*i can cycle through the broken menu with white boxes at the beginning
the monitor only has some small backlight bleeding but has no damage etc.

turning it on(white led is on):

the menu which appears after the white stutter.

broken not working menu: (the sideview of all buttons menu is a big white box)