cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Swift PG278Q - Stuck at 24hz

Godborn
Level 7
Hey ASUS Community and Moderators,

I'm posting this to reach out for some help for my ASUS ROG Swift PG278Q.
I have had this monitor since November 2014 and there has been no issues. However, the monitor has recently had some issues.
The main concern is the monitor is stuck on a 24HZ Setting - regardless if I attempt to override using the NVIDIA Control Panel.

Now when I try to change the HZ Setting on the right panel of the monitor - there is no setting underneath "TURBO"
This is visible here: http://imgur.com/jeA2tRe

This has never happened to my monitor since November 2014 and just on March 20, this started.

Then when trying to change the HZ setting on windows - it too only limits the setting to 24 HZ.

at first, I thought this may be an issue with the cables but I purchased another 1.2 DisplayPort Cable and still had the 24 HZ issue.

Now I'm starting to think it could be the displayport input port at the back of the monitor.
Would this be a possibility?

I look forward to the feedback!

Thank you,
4,800 Views
2 REPLIES 2

william456
Level 7
my pg278q was dead in minutes ago
and that is my RMA Screen
The first time's issue is flicker and text bold,
The secondary monitor(RMA) is all white screen and noise on screen
the first time,i used it 15 months before RMA
the second time, i just used only one months before RMA
56550

56551

Godborn wrote:
Hey ASUS Community and Moderators,

I'm posting this to reach out for some help for my ASUS ROG Swift PG278Q.
I have had this monitor since November 2014 and there has been no issues. However, the monitor has recently had some issues.
The main concern is the monitor is stuck on a 24HZ Setting - regardless if I attempt to override using the NVIDIA Control Panel.

Now when I try to change the HZ Setting on the right panel of the monitor - there is no setting underneath "TURBO"
This is visible here: http://imgur.com/jeA2tRe

This has never happened to my monitor since November 2014 and just on March 20, this started.

Then when trying to change the HZ setting on windows - it too only limits the setting to 24 HZ.

at first, I thought this may be an issue with the cables but I purchased another 1.2 DisplayPort Cable and still had the 24 HZ issue.

Now I'm starting to think it could be the displayport input port at the back of the monitor.
Would this be a possibility?

I look forward to the feedback!

Thank you,

Bump