Showing results for 
Search instead for 
Did you mean: 

Windows 10 Speed of LAN card limited to 100mbit, WIFI gets full speed of 200mbit

Level 9
Since i installed windows 10 my wired connection seems to be limited to 100mbit. i already tried the following things to solve it but without any succes:

tried the windows driver and the asus driver for the card
tried to set it to 1Gbit full duplex
used various firmwares for my asus rt_n66u router
reset the router using the 30 30 30 method and used firmware recovery to totally reset it

Do any of you guys have the same problem, would find it weird it is the router causing this since it worked fine on windows 8.1

thanx in advance for any help

Kind regards

Level 9
hmm, i tried to optimise the settings of my connection with auslogics boostspeed 8 and now i do get the full speed. must be some built in new "feature" in windows 10 :S Glad there are some scripts available to disable most of the, for me, crappy new things in windows 10 like destroy the data collection by microsoft