cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 10 - no network hardware???????????

Concern
Level 7
I just did the Windows 10 update and it did not recognize any network hardware on my G751.

Plugged into network, but not recognized. Six WiFi networks in range, nothing recognized. Go to configure an internet connection and it says I have no network hardware.

Reverted to 8.1 and everything works again.

Anyone else have this issue??

Microsoft support is, of course, useless. They figure if it says no network hardware there must be no network hardware, despite it working in 8.1.
7,664 Views
5 REPLIES 5

clockworksatan
Level 7
Hmm... Not heard of this happening to anyone else and I was able to upgrade to 10 without any difficulties at all. Are the device drivers showing as being installed?

Perhaps it might be an idea to download the drivers for your WiFi/NIC/Bluetooth before trying to upgrade again and copying them to a USB stick or something, then try to install them after the upgrade?
Asus ROG G751JT-T7115H
17.3" IPS, Intel i7-4720HQ, 16Gb RAM, NVidia GeForce GTX970m, 256Gb M.2 SSD + 1Tb SSHD

I´ve bought a new G751 with G-Sync last Weekend and upgraded to Win 10 directly after First Install. My Intel Wlan was found in System-Hardware but i´ve got same Problem, No Wifi was found.
So i went back to my old PC and looked after Drivers

https://downloadcenter.intel.com/product/75439/Intel-Dual-Band-Wireless-AC-7260

unistalled actual Drivers in Systemsettings and installed new one from Intel....after that everything works fine...

G751JY-T7335H (German)

Ditto this, have you updated all your drivers from Asus Support Downloads you should be up to date on all for Win 8.1 and Win 10. I haven't heard any issues with 10 and BIOS Version so update that at your own risk. Also if you haven't all ready download thehttp://www.microsoft.com/en-us/software-download/windows10 ISO and run the update install from that. I'm reading failure are having better luck with the ISO upgrade than the downloaded upgrade.
I'm reading that you mount the ISO in windows and run the setup.exe to start the upgrade that way is working best.
For more information https://www.tenforums.com
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro

mik_sch
Level 7
Hi. I had same problem, ASUS UX32V. I found a link saying it could be because of previous VPN installation (I have Cisco VPN). The solution was on:
http://www.ibtimes.co.uk/how-fix-no-wi-fi-available-issue-after-windows-10-upgrade-1513654
I just did as explained, removed registry entry 988248f3-a1ad-49bf-9170-676cbbc36ba3 and after a reboot I had network.

Concern
Level 7
I did the upgrade from the .iso so that won't help. I will try getting the drivers and putting them on a USB. Thanks for all the replies.