cancel
Showing results for 
Search instead for 
Did you mean: 

VX7 won't post after saving BIOS settings

FrozenLord
Level 7
Hi there,

I have recently started having Problems with my ASUS VX7 and have not found any solution so far.
Seeing that it is based on the G53, I thought maybe you have suffered a similar problem and might know a solution 🙂

My problem is this:
The VX7 won't show any output on display anymore and seems to hang while booting.
Therefore, I power on the Laptop and the usual lights blink once (power and fans stay on), the odd starts shortly but nothing else happens.
There is no output on the internal display and when I plug in an external monitor via HDMI (I have no VGA-device available) there is no output as well.

What led to this situation:
I recently added a SSD to the device and deactivated the HDD (slot 2) in the BIOS, so Windows could be installed on the SSD without getting confused.
This worked flawlessly and the PC booted Windows without any problems, allowing me to install my applications and reboot several times.
When I had finished setting up Windows, I restarted and reactivated the second HDD (containing my files and games) in the BIOS.
After saving and exiting the BIOS, the PC no longer showed any picture nor did it start again for two minutes (which is when I turned it off).
Afterwards, it failed to boot, resulting in the described situation.

What might be helpful to know:
The HDD and SSD used to work as intended, even in the current configuration (I used the exact same configuration before installing Windows, however the Windows setup always ended up writing some part of the Bootloader to the HDD, which is why I deactivated the HDD for the time of the installation. However, I used this configuration to access my old Windows installation on the HDD and it booted up fine, giving me access to the HDD and the SSD).

What I tried to solve this situation:
I tried removing the SSD and/or the HDD, removed all the RAM modules but one (I seem to be unable to find the slot marked '1').
I even tried removing the WLan-Adapter as well, trying to boot the laptop with only one RAM module installed and no HDDs at all, resulting in the same situation.
On various forums, there were advices to unplug the battery and the power adapter and then hold the power-button for almost a minute.
However, this too has not solved my problem.
I tried using an external monitor via HDMI (I have no VGA-device available) and it did't show any output either.

Could you please help me solve this situation?
8,984 Views
13 REPLIES 13

ravincia
Level 7
Same prob with my g74sx. Except mine wont even light up or start the fans. Sad to be in our shoes T_T. I'm considering RMA'ing mine since the warranty hasnt even reached the one year mark. Maybe you should consider it as well? Provided you still have warranty of course.
Asus ROG G74SX-3DE
Upgrading my gear as and when fate allows
I'm an ENTHUSIAST just like you!

For some reason I'm still hoping that someone might know the magic answer for this poblem....
Like: just press x and y while repeatedly smashing the power button to solve the afore-mentioned poblem.

However, that hope is fading slowly 😞

dstrakele
Level 14
See if this post: http://rog.asus.com/forum/showthread.php?10435-My-ASUS-wont-start-when-i-press-power-button&p=72124&... will help you with a BIOS recovery. I've never performed one, so it is unlikely I can help any further.

http://rog.asus.com/forum/showthread.php?10273-G51JX-need-BIOS-recovery-instructions is another thread about aptio recovery that you should read.

If you find you just can't access the BIOS, then an RMA may be your best option.
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

PILGRIM
Level 11
FrozenLord, can you still access BIOS? If so, could you check if your
SATA Mode Selection is set to AHCI (not IDE) in the Advanced tab?..

One more thing, what if you just connect the SSD (where the Windows OS is)
to the primary slot (if it's not there yet) without the HDD?
Would it make any difference?..
ASUS G74SX-3DE

Hi,

Unfortunately, I can't access anything.
The laptop just shows a blank screen - which seems to be turned of (i.e. not even background lighting).
I've already tried using an external display via HDMI (in case of a defective background lighting / display), but there's no output whatsoever...
So for the moment, I'm stuck with a laptop that seems to fail when loading the bios - but I'm not 100% sure, how that can happen by simply saving BIOS settings.

PILGRIM
Level 11
"Can a Windows OS installation or changing BIOS Settings brick a laptop?"

This is the question that consistently stays in me upon reading and re-reading
your thread since yesterday ( it's already past 9 PM here, Asian time).
But I'm also at a loss on how your simple Windows installation and changing BIOS
settings would result to a "bricked-type" situation. Unless the motherboard just died..

ADDENDUM: Sorry to say, but RMA would be the only way here, if all
workaround had failed..
ASUS G74SX-3DE

So far, I'm somehow sure that the Windows installation is not to blame.
I'll stick with blaming the BIOS, which somehow managed to kill itself by saving the settings.

However, there seems to be some routine in place for this case.
I have formatted an USB stick and placed the BIOS on it.
When I put this stick in the first USB slot on the left, and hold CTRL+Home while turning it on, the laptop seems to access the stick (the stick's LED blinks quite a lot for a few seconds and then there is no blinking anymore).
If the stick is on the right side, it only lights up, but does not blink - so there might in fact be a recovery routine.
I left the laptop like that for 15 minutes, however, there is nothing new happening - no LEDs happily blinking away, no post-screen, no funny beep-sounds, no nothing.
Seeing that it could have as well done what there is to do in those 15 minutes, I turned it off and on again, but it simply greets me with a blank screen again.

Is there any special naming convention for the BIOS file?
So far I've got four files on the drive:
AMIBOOT.ROM
VX7AS.ROM
VX7.ROM
VX7AS.207 (the way the file is named after extraction)

dstrakele
Level 14
This thread discusses a successful aptio recovery: http://rog.asus.com/forum/showthread.php?10273-G51JX-need-BIOS-recovery-instructions&highlight=aptio.... From your descriptions, you appear to have the same bootup behavior. Of course you'll need a different BIOS file and will have to name it differently. You'll note the OP is using model# with a .BIN extension. It would be interesting to see if you could reach the Crisis Flash screen.
G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Thanks for the link.
I seem to have the same boot behaviour, but I'm still stuck at the very same step.
So far, I haven't figured out the name it is looking for and have no idea how to find any hints 😞