Showing results for 
Search instead for 
Did you mean: 

Trouble installing Windows on Asus G751YT

Level 7
Greetings, I'm a new member here, just bought this laptop and have a HUGE problem.
I tried to install Windows, and i think I made some big mistake.

I putted the dvd in, and entered BIOS with f2.
I changed the boot priority there, from disk to cd/dvd

After that - nothing was happening!
When i tried to press START button, laptop started, keyboard turned red for one second, and after that everything turns off! Even the ROG logo doesn't show.
I can't open the dvd drive too. It looks like it's totally frozen.
That happens every time when I try to start it. Its ON for one second, than goes OFF.

Please, I hope you could help me because I'm desperate right now.


Level 7
Try pressing (hold) Del button to get back into bios.
Isn't there a way to force eject the DVD? I'm sure there is. If you totally fail, you can totally disconnect the DVD drive from the laptop (but keep that as a last option).

Level 7
luckily, we took dvd out , but computer still won't start. I simply don't understand what happened, i tried to ask some IT colleagues and they said that they have no idea what's happening. It acts like it don't have enough energy to start. Its brand new, came in original box. We tried to enter BIOS few times, but it turns off faster than we are able to type anything.
Now it went back to the store... hope that they will figure something out.