Showing results for 
Search instead for 
Did you mean: 

Thunderbolt error message sometimes at boot G751JY-T7022H

Level 9
Hi everybody,

Sometimes at boot i got :

Thunderbolt(TM) has stopped working

Problem signature :
Problem Event Name : CLR20r3
Problem Signature 01: Thunderbolt.exe
Problem Signature 02:
Problem Signature 03: 530cadea
Problem Signature 04: mscorlib
Problem Signature 05: 4.0.30319.34209
Problem Signature 06: 53489fcf
Problem Signature 07: 16b9
Problem Signature 08: 29
Problem Signature 09: System.ApplicationException
OS Version: 6.3.9600.
Locale ID: 4108
Additional Information 1: 47a9
Additional Information 2: 47a911619a6f7257941f03f0a3f3bd76
Additional Information 3: 5adc
Additional Information 4: 5adc77f494602765147c2b654b90aeb3

Driver Thunderbolt

If someone can give the information to technical Asus Team will be great too.

More information from event viewer :

Event 1000, Application Error :

Faulting application name: Thunderbolt.exe, version:, time stamp: 0x530cadea
Faulting module name: KERNELBASE.dll, version: 6.3.9600.17415, time stamp: 0x54505737
Exception Code: 0xe0434352
Fault offset: 0x0000000000008b9c
Faulting process id: 0x6ac
Faulting application start time: 0x01d05a2f6a838a2f
Faulting application path: C:\Program Files\Intel\Thunderbolt Software\Thunderbolt.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report id: ac56c073-c622-11e4-82ab-28b2bdf6ff4f

And 1 second before in event viewer too :

Event 1026, .NET Runtime

Application: Thunderbolt.exe
Framework version: v4.0.30319
Description: the process was terminated due to an unhandled exception
Exception info: System.ApplicationException
at System.Threading.Mutex.ReleaseMutex()
at Thunderbolt.frmConnectedDevices.CloseApp()
at Thunderbolt.frmConnectedDevices..ctor(System.String[])
at Thunderbolt.Program.Main(System.String[])

Level 7
It seems to be a .NET error.
First, go to Windows Update and make sure you have all the updates.

Then try these steps:
Go to C:\Windows\Microsoft.NET\Framework\v4.0.30319
Open an Admin Command Prompt (File > Open Command Prompt as Administrator);
ngen executequeueditems

after it's finished try
ngen update

After that go to Windows > Microsoft.Net > Framework64 > v4.0.30319
Again open an Admin Command Prompt
ngen executequeueditems
ngen update

Reboot after it's finished and see if there is any problems. If it still doesn't work you could try NET Framework Repair Tool .

Got this result on Framework 64 (all the others commands were ok with message : All compilation targets are up to date) :

C:\Windows\Microsoft.NET\Framework64\v4.0.30319>ngen update
Microsoft (R) CLR Native Image Generator - Version 4.0.30319.33440
Copyright (c) Microsoft Corporation. All rights reserved.
Failed to load dependency stdole of assembly Microsoft-Windows-HomeGroupDiagnostic.NetListMgr.Interop,
Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35
because of the following error : The system cannot find the file specified.
(Exception from HRESULT : 0x80070002)
All compilation targets are up to date.

I am gonna reboot now.

.Net Framework 4 Client
.Net Framework 4 Full

03/09/15,23:08:10] Beginning of new SetupVerifier error logging session
[03/09/15,23:08:10] Build created on June 24, 2014
[03/09/15,23:08:10] For more information about repairing the .NET Framework, see and
[03/09/15,23:08:10] Activity log file location: C:\Users\Svan\AppData\Local\Temp\setupverifier_main_03-09-15_23.08.10.txt
[03/09/15,23:08:10] Error log file location: C:\Users\Svan\AppData\Local\Temp\setupverifier_errors_03-09-15_23.08.10.txt
[03/09/15,23:08:10] Detected operating system: Windows 8.1 (x64)
[03/09/15,23:08:10] Windows directory: C:\Windows
[03/09/15,23:08:10] System directory: C:\Windows\system32
[03/09/15,23:08:10] Program Files directory: C:\Program Files (x86)
[03/09/15,23:08:10] Common Files directory: C:\Program Files (x86)\Common Files
[03/09/15,23:29:59] ***WARNING*** File C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet.mof is not installed on the system
[03/09/15,23:29:59] ***WARNING*** File C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet.mof.uninstall is not installed on the system
[03/09/15,23:30:21] SetupVerifier exiting with return value 0

Finally something 🙂 ---> I will try repair tool and verification tool again

Ok so repair tool telling me to reinstall .net framework and if error not fixed can continue repair and it just create some files to send them (or not) to microsoft.
Since .Net Framework is integrated in windows i think i can not install them with external files.

One solution coulb be to find those 2 files and work on permissions.

Or repair windows but wich windows image should I get ?

Level 7
Could you try enabling NET Framework 3.5 from Programs and Features? Maybe it will help.

You could try running the following code in an admin command prompt:
dism /Online /Cleanup-Image /RestoreHealth

You could also try reinstalling Thunderbolt (uninstall it from Control Panel then download the latest one from

Or, if you don't have any ThunderBolt devices, you could just completly uninstall it. It's not essential for your laptop.

Or just disable it at startup by going to Schedule Tasks > Task Scheduler Library > Intel > Thunderbolt and disable the tasks.

Also, if you go to Program Files > Intel > Thunderbolt and run Thunderbolt.exe does it give you the same error or does it appear in the system tray?

If you need a Windows Refresh Image, Microsoft can give you one through

Level 7
Try using
dism /Online /Cleanup-Image /RestoreHealth
also try reinstalling Thunderbolt.

Or you could completely uninstall it.

Can u get those 2 files and upload them to an online drive please ?


Dism /Online /Cleanup-Image /ScanHealth -----> no damage to the image

Level 7
I don't have those files in my Framework64 folder, and I don't think they are relevant. Thunderbolt and Thunderbolt software works fine on my laptop without that pnet.mof.
If you navigate to C:\Program Files\Intel\Thunderbolt Software\ and run Thunderbolt exe does it start? It should appear in the system tray.

Also: enable NET Framework 3.5 in Windows Features.
Try the following command too:
%windir%\Microsoft.NET\Framework\v2.0.50727\ngen.exe update

It seems that for some reason Thunderbolt can't find some library.

If nothing works, there might be a problem with your Windows installation. If you installed from a corrupted media you can not repair the NET Framework because it will try to "repair" itself with the corrupt Windows components.

The best way to get an official Windows image is

If i launch Thunderbolt.exe it's working 100%. .Net Framework 3.5 installed long time ago. Tried ngen update didn't help everything up to date.
It's not possible corrupted media because it's factory windows install 🙂

I got an image of WIndows 8.1 Core/Pro Update 3. Will reinstall fresh later. It's not a big matter now. But i am plan to use this port for a screen later.
Anyway thanx for your great help JupiterTheGod. Cheers.