Showing results for 
Search instead for 
Did you mean: 

Sudden trouble with wifi on GL552vw (very detailed post)

Level 7
Hello all,

New here. I have an ROG GL553VW. I'm not really even a gamer but I like fast powerful cool laptops. It's mostly worked well last 3 years but there's been some issues. First when I tried to use linux with it, problems with graphic card. No big deal. Then later my internal camera stopped working. I uninstalled and reinstalled the device manager (driver) for it and it was fixed, but then it happened again a few months later. I tried hard to fixed that, talked to support, worked with drivers. I think it uses a generic driver, Human Interface Device. I tried hard, but couldn't fix it, so I shelled out $20 for an external camera. Worked fine, problem solved.

Just yesterday I am having a problem with my wifi. Thankfully I can connect to ethernet here. Every month I get smarter with computers and this iteration maybe I'll be able to go deeper and solve this. It would feel great. Here's the story:

I was eligible for a new router from Xfinity. My old router was capped at a certain speed and they kept telling me to upgrade, but if it wasn't broke I didn't want to mess with it. Then yesterday my old router or network connection did have a hiccup. I got disconnected from zoom and the internet just at my lunch break, which was convenient. I tried numerous things but couldn't fix it but then a straight restart of windows 10 fixed it. Back in business. But that made me decide just to update the router. So yesterday afternoon I went to xfinity and got a new router. It looks a lot better, a compact white router vs a big ugly black box like router.

I followed their setup. It was an easy set up. It worked and was found on every other device- my linux laptop and my android and I think all my roommate's devices.

At first, I could see my SSID "House Wifi" and yes it showed full strength. I'm physically close to the router, within 15'. At first, one of two things kept happening on my Windows 10 machine and only my windows 10 machine:

I could see the SSID "House wifi" but it would either not connect. It would tell me right away it would not connect. Or else if I toggled on and off the wifi (or airplane mode) and turned it back on, it would say connected, secured, but when I went to a website, it would revert to the 'connecting' status and stay there.

I ran a windows diagnostic and was given the following error message "Wireless association failed because Windows did not receive any response from the wireless router"

That was very telling.

So in this time, of course I tried resetting my router, forgetting the network, all the basics, as well as uninstalling my Intel(r) Dual Band wireless AC 7265, restarting my computer. Nothing worked. That was the first half of the evening.

I did some other settings in network and sharing center of the control panel. I disabled everything but the ethernet, which thankfully works, and the wireless. I disabled and renabled the wireless. I played around with properties of ipv4 and ipv6 including dns. All this should be good. I disabled all the virtualization and vpn connections. I'm not sure if this has anything to do with what followed or is just coincidental but during the second half of the evening, and right now the following morning, I could not even see my SSID (network name), yet I can see other SSIDs. I can still see it on other devices, and connect to it. Again, only on this Windows (I have not tried other windows devices as I do not have any) I cannot see my SSID but I can connect to the router via ethernet. We also tried last night to factory reset the router. That didn't work. I can get into the config page at and look around there but I coudln't find anything that worked or looked promising. I tried assigning my device a static ip number as opposed to DHCP, giving it it's subnet mask and all that. I kinda know a little about that, but not that much. That didn't work. I ended up reseting those settings to auto. I also noticed in the gateway config page ( and my xfnity app that it did show my desktop as having been connected at one point a few hours prior (when I started the router) but that it was currently not connected). I never once got a page load or anything to indicate connection but Xfinity thought I was connected at some point.

Of course I ran the diagnostics tool numerous times. MS pats itself on the back and thinks it found the answer when it says "Such and Such random SSID is not set to automatic connect". As if. Man. I tried to connect to other open networks with weak signal but it didn't connect. I don't know if that's a function of general failure to connect or just the networks. I want to test this at a public wifi and see if it will connect to a public hotspot. Honestly if it will connect to others, and I can use ethernet at home, which I just started doing, and if my roommate's aren't having any problems, I'll just due that. Most coffeeshops are closed due to covid but I can figure it out. If it doesn't connect to any hotspot (though they show up, with varying signal strengths), then we have a deeper issue.

That's most all of what I tried last night.

What I tried this morning was rolling back a the latest windows update, which was yesterday. I did so and restarted, but it looks like it reinstalled as of today 1/30/2021, so I paused installs. I did the same, but it still looks like it reinstalled as it shows I can install the update of 1/30/21. I give up. Do I really give up?

I tried that. Didn't work. Oh yeah yesterday I tried reseting winsock in the terminal and the network inside the windows settings, restarted my computer, and it didn't fix anything. The network didn't show up under ipconfig or whatever the command is either.

Today I also started talking to a windows support staff. He suggested downloading the network drivers from Asus.

I did that, I downloaded them. He said to restart computer (before installing). I did. The old drivers came back. BTW I don't have option to rollback any drivers. That option is grayed out on my machine. I haven't been able to reconnect to him on chat. Actually after chatting with him, and restarting, my computer was stuck in 'getting ready', for half an hour. It said do not restart. I read online about this and people said their machines have been stuck in that state for hours and days, so I just powered down, disconnected cables and restarted (my current session). I'm glad I didn't break anything. I installed all the updates to current state (one was a .NET framework thing that I happen to have. I think it's a visual studio SDK or something, that I probably won't use). I haven't been able to get him or anyone back on the chat, though we have our message log. I have a support number.

Alright so I haven't installed the drivers I downloaded from Asus. I'm willing to but there's one caveat about the Networking driver. I extracted it and was reading the instructions and FAQs. So far so good. I clicked on the installer, and it talked about Ethernet. Ethernet is right now my only connection to the world wide web and I don't want to break it. If I break ethernet I am done, potentially. Besides ethernet is not my issue, wifi is. So maybe that's just semantics and if I did the instructions or ran the installer, all would be well and wifi would be fixed. Or maybe all would be well with ethernet but wifi would not be fixed. Or maybe it would be broken but I could fix it without an internet connection, which is fine. Or maybe it would be broken and I coudln't fix it wihtout an internet connection, which is the scenario I'm most worried about, so I haven't installed it yet (the Networking driver Version V10.8.311.2016
2016/08/16 Realtek LAN Driver from I actually see just below it, if I click more, that there's a driver dated one day prior, that is RealTek Wireless Lan Driver and Application. I'll try that after this forum post. If I report back success, then it's good, otherwise assume failure. Maybe that's the one I need

Also I noticed my bios version is 202 and the latest is 306. I downloaded the latest bios from Asus but haven't installed it. I'm happy and willing to if I can be reasonably confident nothing will break or my computer will not be bricked. I'm a little nervous about this but that's mostly because I haven't researched it at all. We'll see what that does. Perhaps that will fix both my old webcam issue and my wireless. Who knows. BTW I forgot to report, I was in BIOS earlier (or UEFI) and turned off both virtualization settings, just to check on that. Nothing else looks funky in BIOS.

So where I stand, I will see about the Realtek Wireless Lan Driver and Application and about BIOS but any pointers you can give me there would be great, or any knowledge you might have would be great. The MS support agent told me to run some command prompt commands but they didn't find or fix anything:

Dism /Online /Cleanup-Image /CheckHealth

Dism /Online /Cleanup-Image /ScanHealth

Dism /Online /Cleanup-Image /RestoreHealth

Also run the System File Checker utility:
Open Start, type: CMD
Right click CMD
Click Run as administrator

At the Command Prompt, type: sfc/scannow

Any knowledge or insight you have would be great. It's frustrating but also a great learning opportunity. I'd be psyched if I fixed this. I'm learning to code and data structures and algorithms but I'd rather not foucs on the windows 10 but if I can get a win here that would be huge. I've probably invested 6+ hours at this point. I like Windows mostly but the updates and bugs are what drive me crazy. I wanna stick with windows if they can handle these types of issues. I felt like I could handle them by being smarter, understanding drivers, regedit, advanced settings would allow me to overcome any conflicts that may arise, but apparently not. Perhaps there are some issues that even someone with perfect knowledge cannot fix in windows just because of the nature of the problem and his access. Who knows. But to understand better what's going on would be great.

It seems like a Router-Device communication thing. Remember that diagnostic earlier? "Wireless association failed because Windows did not receive any response from the wireless router". That could be the big hint (and I googled and tried stuff), but that was when the "House wifi" still showed up in the GUI. BTW when i tried to manually add a network with the same name, it said one already existed. I can't remember where I accessed that method.

I could try playing around with all the driver settings like Channel Width, HT mode, and ~18 others, whatever those things are.

In settings, my network properties for the intel wifi it shows under my MAC address the status: Not operational. It shows connectivity: disconnected which makes sense, but it also shows the same for my bluetooth, and testing out my headphones, that worked fine and still showed Not Operational. Only ethernet of all connections show operational (and connected to the internet).

Both ethernet and wifi show same default gateway ( but ethernet shows also an (assumed) ipv6 default gateway

I've never done a Windows reset. I don't want to lose data and all my apps. I could look into that but I don't want a bigger headache than necessary.

I can't think of anything else to ask or mention. I'll look in the asus wifi and bios installations, manual and automatic and I'll proceed with caution. I've never gone this deep.

I hope someone here can share any insights. BTW does Asus/ROG/this version of laptop tend to not play nice with Windows? It's been mostly good and I haven't made any big changes recently. Hopefully there's an answer somewhere. There has to be some reason somewhere. If possible, can one install a new physical card? That could be something I could look into but I don't want a bigger headache from side effects. Its' not about the money but I don't want more things to have to deal with if I go that route, assuming that is a valid route. Have I given this enough effort or am I being lazy?

Thanks in advance!

Level 7
Follow up,

So I miswrote, my model is GL552VW not 553 but I tried installing the correct Wireless drivers for the right version and nothing helped. I don't know if my install was overwritten by Windows or if it just happened to be the identical driver, but it shows the same date and version.

Also, I'm the proud new owner of a new BIOS version as of a few minutes ago- from version 2010 dated 2015 to version 304 dated 2019.

Glad my computer wasn't bricked lol. I didn't do flash bios. I found there was winflash utility and it went smoothly.

However my problem with the Wifi persists. I have to see if it can connect to ANY network first. Then if so I can try to get an earlier router and try that.

Also BIOS didn't seem to fix my camera driver either. I was hoping it would fix everything as it was a 4 year old driver. Well four years older than the most recent.

Is there anything I haven't tried?

I am grateful.. that I still have ethernet. I can still do my day job without having to get a new PC- for now.
I am grateful.. I have another laptop.
I am grateful.. for my health and everything.

But man, this is tricky.

ps I always used to think a driver is just a single file thing, or maybe a file embedded somehow into the OS or memory, but no it's actually multiple files, librarys and so on. So when I tried to install the Asus download wifi driver, I used the .exe wizard. In the device manager, would I go to "add legacy hardware"? Granted this might not even be at all related to what's the issue. I see there are other Intel Dual Band Wireless -N versions e.g. multiple 7265 and (intel, intel, intel and microsoft respectively) and those with other numbers (3160, 8260 8275, etc). Edit: I see that 8265 is a physical card I'd have to buy and install. I'm willing to go that route if need be but first I'll rule out connection to other Hotspots.

I got it working, though I don't know exactly why it started to work. 2 things I did in this session. I think the solution was #2

#1 from here
Type netsh winsock reset and select Enter.

Type netsh int ip reset and select Enter.

Type ipconfig /release and select Enter.

Type ipconfig /renew and select Enter.

Type ipconfig /flushdns and select Enter.

Reason I don't think it was this was because I did a few of these commands before, though not all of them, and it didn't fix anything. Additionally it said it required a restart and I hadn't gotten to that point. Additionally it didn't work after I ran these commands. I thought it was a dud.

20 minutes later reading up on intel 7265 I find this form thread and specifically the post near the bottom

#2 I turned off bluetooth- nothing fancy, just turning it off in the settings, and then I check my list of networks and I know right away it worked because I see the two XFINITY networks that I stopped seeing before- at full signal, and then I see my own. I connect to my own, and it connects. I unplug ethernet and I'm still connected. Woo hoo. I don't know what the issue was. I wasn't even using Bluetooth- not even passively I'm aware of. I don't use it much on this machine. I usually avoid instructions referring to it as I think it has nothing to do with wifi but maybe they interact and create some kind of interference. Maybe it was showing all the networks that were 2.4 gHz and not showing or connecting to all the 5gHz. Hell if I know.

I didn't get any conclusive answers but I learned some things, updated my BIOS, got an updated router and I know it is compatible with my system. Saw down into my computer a little bit. I know it's possible to fix if it happens again- just gotta keep searching. Toggle bluetooth. Bluetooth and wifi might be related/interfere. Are they running on the same network adaptor card? I like to know how things work on the lowest level, the physical level, so if they are running on the same card,
it's easy to see how they might be interfering or hogging some channel or port. I'm just speculating but I don't have to unplug the 10 things connected to this PC and drive out somewhere, and I can use Ethernet now AND I didn't brick my PC or lose data, though I did spent 8 hours (est), I consider this a win.