cancel
Showing results for 
Search instead for 
Did you mean: 

Sonic Suite V2.4.13 not installing

kingswillz
Level 9
I tried installing Sonic Suite V2.4.13 as it's listed on the Asus site for Drivers & Tools for my model and it asked me to uninstall my old version of Sonic Suite.
I did, restarted and tried to install this new version. Now, it gives me the popup saying my audio driver is obsolete and to update it.
The thing is, the audio driver I have is the latest one that's shown to me on the Asus Drivers & Tools page.
I did see people suggesting installing realtek drivers but provided no actual source.
I actually did try to get a new realtek audio driver a while back and that caused a Critical_Process_Died BSOD.
I must admit, I did do weird things but mostly due to the fact when I did install an updated driver, Sonic Studio wouldn't work or the audio sounded weird.

So, basically if anyone knows how I can do this successfully, I would appreciate it.
If I shouldn't bother with this and should just reinstall the old Sonic Suite, let me know.

Model: G752VT
Current Realtek High Definition Audio Driver: V6.0.1.7831
14,221 Views
14 REPLIES 14

Hello my friend, you can to uploading again this audio drive V6.0.1.859_FF03 for me, because my Asus sonic suite no working. Thx in advance 

Dimitrios1971
Level 12
Hi,
Yes, install everything first to get a better overview if you have problems to identify them again.

OLD


NEW

niesayat
Level 7
Rog game first v when I on my gaming in the inthernet I receive is became low. we had a speed of 250mbps net speed. when I on became the game first v it became 16mbps only. when I off it became 248mbps or more.. better not to use the game first v. I had a laptop rog strix hero edition GL503VM. I don't know why. before it woking fine. now nothing it seems useless the one in the game center I had its not working. ROG GameVisual, Sonic Suite & GameFirst V.. I download in ROG Global.

winyl
Level 9
This is kown problem after KB4517211 OS Build 18362.387 MS did something to UAC and it now blocks Sounic Suite 3 and 2. Yes 2, too. It is the same thing on Alienware Sound Center.. I experience this after January 2020 cumulative update OS build 18363.628 and on sonic Studio 2.4.13.
We have to wait for a resolution from MS,Asus and A-Volute. Meanwhile you can do this.

Dimitrios1971
Level 12
I think your notebooks is not v3 compatible. So not UHD audio A-Volute...
The latest for your notebooks HD driver is 8858.1_FF03

OLD


NEW