Showing results for 
Search instead for 
Did you mean: 

ROG G751JM not CHARGING ISSUE. Please help

Level 7
I got a G751JM and the problem is that it is not charging. But putting my mouse over the battery icon, it says "plugged in, charging." After some time, the computer goes to sleep/ shut downs automatically (not sure which of the two occurs). Then the orange light indicator will blink, saying "plugged in, not charging." I tried the device manager battery driver uninstall. After uninsalling the Microsoft ACPI-Compliant Control Method Battery, it automatically requests for a restart. When prompted not to restart, battery icon will go missing for a couple of seconds and will be right back. I need help please.........

Level 7
What % charge is the battery at?

Snelk wrote:
What % charge is the battery at?

0% already. when i remove the plug, the pc dies

Hi mate!
I just got the same problem.
It is my second case actually.
What was your solution?
Did you change the battery?

Level 7
I had this issue once, let your battery run completely flat, try to start the computer several times until it's for sure dead.

Then leave it charge for at least 8 hours.

This is the battery calibration procedure I got over the phone from an asus rep and it worked on my g751jt.