cancel
Showing results for 
Search instead for 
Did you mean: 

Question about Realtek affecting 3.0 Usbs

Fehaya
Level 7
so everytime i try and install realtek's latest drivers my USB 3.0s which is pretty much every USB on this g750 tends to stop working so i try and remove em restart then theyll always come back with a exclamation mark on them and not work. What am i doing wrong?
4,932 Views
15 REPLIES 15

hmscott
Level 12
Fehaya wrote:
so everytime i try and install realtek's latest drivers my USB 3.0s which is pretty much every USB on this g750 tends to stop working so i try and remove em restart then theyll always come back with a exclamation mark on them and not work. What am i doing wrong?


Fehaya, I think I only saw one post last year about the Realtek driver causing a USB 3.0 problem. What version of Windows are you running? What is the version number of the Realtek driver you are installing? And which version of Asus USB Charger Plus do you have installed?

Updating to Windows 8.1, and installing all the latest Windows 8.1 versions of the hardware drivers and Asus software from the new G750JM/JS/JZ download areas fixes all the problems reported so far, you could give it a try.

Some have had a problem with the older versions on Asus USB Charger Plus on Windows 8.1 - I am at version 3.1.8 and don't have any problems - Downloaded from the JM download area:

http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G750JM&hashedid=hk9WNtlEOFPl0Q7s

Fehaya
Level 7
Honestly i dont know what version of Realtek i was trying to install but it seems like it was the latest one, it has 2XXMB and when i looked that the other ones they were all around 1XXMB. My Realtek right now is 7164 and my USB Charger Plus is 3.1.8. My system is running on Win 8.1. If it also helps the Realtek i install would come with the Audio settings which lets me tinker around with the Bass Treble and the EQ. Lastly it lets me choose from a set of EQ like the one from the site. (Soundscape, Action, Multimedia, Etc.) Im positive it was Asus Audio Wizard.

Fehaya wrote:
Honestly i dont know what version of Realtek i was trying to install but it seems like it was the latest one, it has 2XXMB and when i looked that the other ones they were all around 1XXMB. My Realtek right now is 7164 and my USB Charger Plus is 3.1.8. My system is running on Win 8.1. If it also helps the Realtek i install would come with the Audio settings which lets me tinker around with the Bass Treble and the EQ. Lastly it lets me choose from a set of EQ like the one from the site. (Soundscape, Action, Multimedia, Etc.) Im positive it was Asus Audio Wizard.


Fehaya, do you still have the download link for the new one you were trying to install?

Here is the link for the version I am running, version V6.0.1.7188
http://support.asus.com/Download.aspx?SLanguage=en&m=Audio&os=30

Update: I think I see the problem, someone at Asus has posted some old version 7183 ahead of and a newer version 7195 behind the 7188 version I tested, I haven't tried those. If you have a problem with 7183 or 7195, try 7188 🙂

36411

Fehaya
Level 7
ahh i think you nailed it, i will try 7188 now but is there a difference between global DLM and global? just so i dont screw this up again and thank you guys for helping and pointing that out.

Fehaya wrote:
ahh i think you nailed it, i will try 7188 now but is there a difference between global DLM and global? just so i dont screw this up again and thank you guys for helping and pointing that out.


All the download options should deliver the same bits, but one time it didn't 🙂

I use the regular Global, the DLM is Asus's download manager, didn't help me get things any quicker, and I think I used the P2P once, but 99% of the time I stick with the normal straight download.

Fehaya
Level 7
lol i see and thanks again for the help i will now download this and tonight and sleep it off, i will update this thread tomorrow wether its been resolved or not. Have a good day or night sir.

Fehaya wrote:
lol i see and thanks again for the help i will now download this and tonight and sleep it off, i will update this thread tomorrow wether its been resolved or not. Have a good day or night sir.


Fehaya, I've installed 7195, and it is working for me. Have a nice night's sleep 🙂

Fehaya
Level 7
yeah it worked for me as well thank you so much. And btw if i was to replace a hard drive specifically the smaller one, which one would it be and how would i be able to boot up windows 8 without the main hard drive inside it? (sorry im really not tech savvy, i have a 1TB from my old laptop so i was hoping to pop that in the G750 and end up wth 2TB.)

Fehaya wrote:
yeah it worked for me as well thank you so much. And btw if i was to replace a hard drive specifically the smaller one, which one would it be and how would i be able to boot up windows 8 without the main hard drive inside it? (sorry im really not tech savvy, i have a 1TB from my old laptop so i was hoping to pop that in the G750 and end up wth 2TB.)


A boot drive is needed to boot, so if the boot drive is the smaller drive you can clone it first onto the new 1TB drive before swapping it in to the Bay 1 position. Bay 1 is the left one with the access panel off and both drives oriented such that there are two on the bottom of the laptop.

If the smaller drive is the one in Bay 2, the non-boot drive, you can copy the data on that drive to the new 1TB drive and physically swap it in.

You can put the 1TB drive into an external 2.5" USB 3.0 enclosure (USB 2.0 is too slow) and then clone or copy to it there before swapping the 1TB for the smaller drive.

I use Macrium Reflect for cloning: http://www.macrium.com/reflectfree.aspx