Showing results for 
Search instead for 
Did you mean: 

New RoG G703 user & features/buttons not working

Level 7
I literally received my new RoG G703 laptop a couple hours ago and ran through the Windows req'd setup. Been sitting at the desktop screen trying to figure out why none of the RoG buttons (Aura/xbox/video/Game Center) work and also finding that they do not exist as icons on the desktop or taskbar, nor come up when searching through the computer in either file explorer or Cortana.

I have tried finding an answer through the Asus community forums, Reddit, and Google. No luck. This includes having read the entire 114 page manual for the laptop system too.

Does anyone know of a specific website, guidebook, etc., that I can go to/receive for solving my issues? Thanks!

Note: Aura sync works with a single wave in red when the laptop goes into sleep mode after not being used. That's the only time I have seen one of my issues actually working...

***This was the only response someone was kind enough to send my way through Reddit. Interestingly, a website I never came across searching around for hours prior:

I am not a computer geek, so I am hesitant to start downloading/updating/changing/etc., anything that affects how the system was built without knowing what I am doing, why, etc.

Level 12
As much as was paid to own this beast, I would return the laptop for a replacement.
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

Level 9
If you look in the apps list you should see Asus Keyboard Hotkeys. That should be loaded at startup but click it and see if that helps. The Xbox key seems to only work when you have a game going. It also takes two pushes on the Gaming Center button for some reason. I'm surprised a non-geek spent that much on a gaming laptop. You also need to review the Asus webpage you linked at that is the goto for driver updates. Also look through all the FAQs there.

Thank you to both responses. I double-checked through the apps & features and none of the featured software exists there either. I did not know about having to press the Game Center button twice. Tried it by both double-tapping it real quick and a slower press/release/press of approx. a second for each. Neither worked. Was able to get into contact with an ASUS rep this afternoon, and after explaining and walking through a few things, was advised that these and other features the rep asked/checked with me on should already be preloaded and working on the device without requiring me to do anything to get it working. Was informed that it is defunct and that I will have to send back to the company I bought it from to receive a replacement. Currently informed the company about this to swiftly confirm and figure out the final solution. Will update here any additional info, one way or another, as to what and how it gets resolved.

As for a non-geek buying such an expensive laptop...I have very little time for entertainment and prefer to use it for gaming, etc. vs tinkering around. That's what being a dad with a crazy work schedule/traveling, Grad school, and volunteering life leaves me with. Plus I just can't beat mobility with decent power to handle processing intensive workloads for studies and job. Just buy the best, use it a couple of years, repeat. ASUS impressed me with this system, as I am a former MSI user.

Again, thanks for the input and ideas.

Level 9
I had a similar experience with an Asus GL702, refused to boot after 3 weeks and had to return it for a refund. But, I would up with the G703 which is a good thing 🙂

Good luck with the replacement, and you should never use the word "mobility" in the same paragraph with G703.

Guys does anyone has a keyboard firmware for G703vi?because my rog keys doesnt work either