cancel
Showing results for 
Search instead for 
Did you mean: 

Launching Game Maxes out Brightness

dbrisingr
Level 7
Hey guys new user here (be lenient ^^).

As the title says, everytime I launch a game the laptop just maxes out the brightness, no matter what I do.
I tried adjusting NVidia settings (allow nvidia to control, don't allow application to control).
An interesting thing is if the game is windowed, there is no 'maxing out'. It's only when the game is launched full - screen.
Even if I alt-tab and set down the brightness, when I alt-tab back, I get max brightness again.

Any suggestions?

Thanks.

EDIT: This is G55VW.
6,325 Views
18 REPLIES 18

Zygomorphic
Level 17
It is possible that the game is doing it. Try looking for brightness settings in the game's settings and see what can be changed. Oh, and welcome to the forum! 🙂
I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
http://rog.asus.com/forum/group.php?groupid=16
We now have 178 people whose systems will not break! Yippee! 🙂
LINUX Users, we have a group!
http://rog.asus.com/forum/group.php?groupid=23

Silverkid
Level 7
I have the same problem and I noticed this happens only with DX11 games.

Pitcher1
Level 9
hi, if play other games happen or not? is game name maxes?

colpolite
Level 9
This is the issue I had with my g55 that I had and already returned back in September. It is called the force brightness maximum issue. It also forces the brightness to 100% when you log off for a few sec then back to user preferred brightness. Me and Cman tried to find a solution for months but to no avail.

dbrisingr
Level 7
Thanks for the replies guys.

To the first reply, there are some games that does not have a brightness setting (ie Metro 2033).
Some games I play (eg Starcraft II, Dota 2, FEAR) maxes brightness the first time I launch it, but after this launching the games will have normal brightness.

Is there no way to fix this? I think it also has to do with a game not having a brightness setting. Or like Silverkid said, games with DX11.

😞

kambanka
Level 7
It's not games only. With me it happens when opening ASUS Smart Gesture, too. See http://rog.asus.com/forum/showthread.php?26776-G55-Was-it-a-mistake-(Or-why-Asus-has-no-idea-what-th...

dbrisingr
Level 7
😮

So apparently a lot of users are having trouble with the exact same thing, and no solutions have been found so far?
Maybe update BIOS?

TT

kambanka
Level 7
I already did update. Nothing.

Shawnnepc
Level 13
Did you try removing the NVIDIA 3D driver? Lightboost will cause the same thing to occur
USA ASUS Reseller
http://www.neteffectspc.com