Showing results for 
Search instead for 
Did you mean: 

Keyboard won't light - BIOS updated; G53jw [solved]

Level 7
I reloaded my G53jw a few weeks ago and now the keyboard won't light.

All my drivers in Device Manager are reporting functional and WinFLash is reporting that my BIOS is 2.11 which is the most-recent version I can find on the Asus download site.

I know the keyboard lighting is connected and the LEDs are functional because when I boot they flash on for 2-3 seconds at boot then shut off after the BIOS loads. After Win 7-64 starts, the keyboard lighting remains non-functional even if I hit Fn+F4 or any other button. Last, the little "Lighting On/Off" button at the topmost left corner of the PC will toggle JUST the lit keys at the very top of the keyboard on and off (the power button, Asus logo button, etc.) but the keyboard does not illuminate along with them.

I'm thinking there's a software setting somewhere that's disabling them, but I can't for the life of me see anything I need to toggle on to illuminate them - can anyone assist me?

Thanks a million in advance!

UPDATE: THe problem is exactly as described in this Yahoo Answers thread re: lighting control and my (currently non-functional) Performance button, however there's no answer there (provided for addional background info if needed to diagnose):


Level 7
Sorry guys, but this is SOLVED (found it 5 minutes after posting this... go figure). The solution was uninstalling the Asus ATK package and re-installing using the file located here:

After a reboot, all my Function keys (including the backlight control) seem to be working. Sorry if this is old news; I didn't find it on the forums despite multiple searches so hopefully it will help someone).

PS - can a moderator change the thread title to add "SOLVED" to it?

Level 9
you mean when you reinstall atk and install atk utility from G53 webpage can not fix?