Showing results for 
Search instead for 
Did you mean: 

Internet connection/download problems right out of box

Level 7
I purchased a brand new ROG 751JY from AMAZON. The computer worked great for around 1 hour, just enough time for me to
connect to my wireless,download google chrome, my photoshop program, Adobe Premier elements 12, Avast,Malwarebytes,
steam and a few documents. I then too the PC downstairs and for what ever reason the computer now rarely wants to connect
to the internet. When it does connect, it sits at 98% download and just sits there on what ever I download. I figured maybe it was
a bad google chrome install, so I uninstalled that, now I can't even get it re-downloaded. It sits at 98%. I've even tried hard wiring
my internet to it in case wireless router was acting up, nope same deal.

Not sure what could have changed or what is wrong but I can't download anything. I even tried using Internet Explorer and the
downloads to the same thing, they get to around 98% and freeze. I even tried to do windows updates, they start and get to around
30% and just sit for hours. Does anyone have any idea or clue what to do on this brand new laptop? I was told to try and refresh/reinstall windows...but uh...this Laptop came with no restoration CD and when I clicked "Refresh" it said I'd have to have the apps/CD's
to reinstall all the software it's about to remove so I exited out of that as I didn't want to make this thing worthless and then be
really screwed...If anyone has any info I'd appreciate it as I can't get anything installed and haven't the slightest idea what could
have changed or broke from installed the above programs. Oh I also installed the latest Nvidia drivers if that could have done

P.S I've had google chrome trying to re-install for 2 hours, it sits at 98% downloading, errors out then tries to reinstall and does this over and over. If anyone asks, Yes I've restarted my router to be safe and restarted the PC Several times.

Level 7
Just so everyone is aware and might be having the same problems as me, I uninstalled AVAST Anti-Virus and it fixed the problem instantly with my downloads hanging at 98%. Hope this helps anyone else having the same issues as I did.

Level 7
Try also removing Gamefirst III as mentioned on this topic:

By information available, it seem that's the main source of that kind of behavior and removal of it helped me

Level 7
Problem solved! I had the same problem as the OP.
So, I checked "Services" first, but Gamefirst doesn't appear there. Went to Change Programs, and deleted the program. Restarted the machine, and tried the Java "Run" download again.
The installation package downloaded in seconds, and installed JRE very quickly. I then started the Minecraft 1.8.1 installer, and it likewise installed quickly.
My son is ecstatic!
FWIW, Avast! Free is loaded on the machine. I didn't mess with it; it doesn't seem to be the culprit.
Thanks, ibuljeta!